Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are using TFS2010 with the SharePoint document portal. We are trying to access the files in SharePoint using UNC paths (e.g. \\tfs2010\sites\DefaultCollection\MyProject) and it just plain doesn't work.

From my workstation, I actually get different behaviours depending on the path.

Case 1: Path = \\tfs2010\sites\DefaultCollection\MyProject\ Result: windows explorer reports a network error "Windows cannot access \\tfs2010\sites\DefaultCollection\MyProject\"

Case 2: Path = \\tfs2010.mycompany.com\sites\DefaultCollection\MyProject\ Result: Windows Security dialog pops up asking for my username and password. I tried entering all combinations of my windows username and password (with and without the domain before the username), but no matter what, my credentials are not accepted.

I have no problems accessing the SharePoint site through the web portal - it's just UNC which doesn't work.

There doesn't seem to be anything relevant in the event viewer on the server.

Anyone have any idea what could be the problem?

share|improve this question
    
Those are typos, right? As in, most UNC paths start with two slashes and not one. Also, have you tried to access it over the administrative share? (Driver letter followed by the dollar sign, followed by the actual path on the remote server?) –  HopelessN00b Jun 22 '12 at 20:37
    
oops - typos fixed. my double backslashes got interpreted as some kind of markup. –  RobSiklos Jun 25 '12 at 0:27
add comment

1 Answer

  • I assume you're on the same domain as server and are properly entering your logon when UNC prompts (either domain\user or user@domain.com).
  • What OS is your workstation? I believe UNC access requires the WebDav Client service be running, and it's not running by default on all Server OS's.
  • Is tfs2010 the actual server name or an alias? If it's not the actual servername, you may be having Kerberos issues with authentication.
  • ULSViewer is your friend. Run it on SharePoint server, point it to logs default location and watch it while you try to UNC to SharePoint. 90% of time I can discover the problem with USLViewer.
  • Try going in a standard (non-TFS) SharePoint document library and click the "open in explorer" button. Does that work?
  • Bonus tip: The reason \tfs2010 doesn't prompt for login and the FQDN does, is that it's using Internet Explorer security zones, and assumes anything with a FQDN is not trusted for passthrough authentication. To fix this, add tfs2010.mycompany.com to the "Intranet" zone.
share|improve this answer
    
Yes, same domain. Workstation is Win7 x64, and the WebClient service is running. –  RobSiklos Aug 22 '12 at 16:18
    
I tried another (non-TFS) sharepoint server from my workstation, and used the "Open with Explorer" option from the "Library" tab in the ribbon. It successfully opened a new Windows Explorer window with an "http" url to the document library –  RobSiklos Aug 22 '12 at 16:19
    
Also, just verified that tfs2010 is the actual name - not an alias –  RobSiklos Aug 22 '12 at 17:14
    
Just tried ULSViewer. Nothing came up in case #1, but in case #2 there was a message about the URL not being configured in "Alternate Access Mappings". My guess is once we fix this, case #2 will just behave like case #1, so I don't think it's worth pursuing that option. –  RobSiklos Aug 22 '12 at 17:43
    
I'm not a TFS person. Have you validated that TFS supports opening in Explorer? Is it just a Document Library with source code in it? –  Bret Fisher Aug 22 '12 at 20:29
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.