Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install Munin on a new VPS through yum install munin but I keep getting an error about a missing perl module: Requires: perl(:MODULE_COMPAT_5.8.8). This is the perl version currently installed: v5.10.1.

I've searched all around and still haven't found a solution for this.

Here's the relevant part of the output of the installation attempt:

--> Finished Dependency Resolution
Error: Package: perl-Mail-Sender-0.8.13-2.el5.1.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Log-Log4perl-1.13-2.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Mail-Sendmail-0.79-9.el5.1.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Log-Dispatch-FileRotate-1.16-1.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Crypt-DES-2.05-3.el5.i386 (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-1.4.7-5.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-IO-Multiplex-1.08-5.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-common-1.4.7-5.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Net-Server-0.96-2.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-Log-Dispatch-2.20-1.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: munin-1.4.7-5.el5.noarch (epel)
           Requires: bitstream-vera-fonts
Error: Package: perl-Net-SNMP-5.2.0-1.el5.1.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-HTML-Template-2.9-1.el5.2.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
Error: Package: perl-IPC-Shareable-0.60-3.el5.noarch (epel)
           Requires: perl(:MODULE_COMPAT_5.8.8)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
share|improve this question
    
Just to note that git (or the perl-Git package) on CentOS 6 also seems to have this broken dependency and the fix is the same. –  Jona Dec 3 '12 at 15:18

4 Answers 4

up vote 13 down vote accepted

You are using the EPEL 5 version of the repo instead of 6, go into your /etc/yum.repos.d/epel.repo file and change:

mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=$basearch

to

mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-6&arch=$basearch

Then run yum clean all and then try and install munin again.

NOTE: you may have an issue with the GPG key being different, you need to grab the EPEL6 one or just use:

yum install munin --nogpgcheck
share|improve this answer
    
Thank you. I've had this problem for a while going around in circles till I push it aside. Now in 1 minute, your post has solved countless grey hairs and bald spots. –  Eric Leroy Dec 23 '13 at 11:57
    
These directions worked on 2 of the 3 servers I was working on. The last one required me to do the following: yum update --skip-broken. Wanted to make a post in case anyone else needs it :) –  VenomFangs Sep 23 at 23:51
    
Another option is for them to delete the file and perhaps install the correct repository :) –  VenomFangs Sep 23 at 23:53

I think you the yum configuration on the system is confused. It appears to be trying to install munin from the Centos5 (hence all of those references to '.el5') repositories instead of from a Centos6 repository and that will not work. Also once you have removed the Centos5 repositories from the configuration, be sure to run yum clean all before yum install munin.

share|improve this answer

just remove the repository form its place rm /etc/yum.repos.d/(added repository) and yum clean all and yum install (whatever)

share|improve this answer

If you have CPanel look into /etc/yum.conf and take out perl* from exclude list

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.