Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The routing on my Juniper EX3300 does not seem to be working. My ISP's gateway is at xx.xx.xx.xx. And I have the following in the configuration:

routing-options {
    static {
        route 0.0.0.0/0 {
            next-hop xx.xx.xx.xx;
            retain;
        }
    }                                   
}

I can ping to my ISP's gateway from the switch. However, I can NOT ping to any other IP. When I do a traceroute (to Google.com's IP). This is what I get:

traceroute to 74.125.224.69 (74.125.224.69), 30 hops max, 40 byte packets
traceroute: sendto: No route to host
 1 traceroute: wrote 74.125.224.69 40 chars, ret=-1
 *traceroute: sendto: No route to host

Do I need to enable any protocols? I guess this goes without saying, but I am kind of new to Junos.

Update: This is the output from show interfaces terse | match inet:

bme0.32768              up    up   inet     128.0.0.1/2     
jsrv.1                  up    up   inet     128.0.0.127/2   
vlan.0                  up    up   inet     10.0.1.1/24     
vlan.1                  up    up   inet     xx.xx.xx.110/30

and this is the output from: show route forwarding-table:

Routing table: default.inet
Internet:
Destination        Type RtRef Next hop           Type Index NhRef Netif
default            perm     0                    rjct    36     1
0.0.0.0/32         perm     0                    dscd    34     1
10.0.1.0/24        intf     0                    rslv  1321     1 vlan.0
10.0.1.0/32        dest     0 10.0.1.0           recv  1319     1 vlan.0
10.0.1.1/32        intf     0 10.0.1.1           locl  1320     2
10.0.1.1/32        dest     0 10.0.1.1           locl  1320     2
10.0.1.3/32        dest     1 0:25:90:63:26:53   ucst  1331     2 vlan.0
10.0.1.255/32      dest     0 10.0.1.255         bcst  1318     1 vlan.0
share|improve this question
    
Can you show me the output of show int terse | match inet and show route forwarding-table? –  bahamat Jun 22 '12 at 23:03
    
@bahamat I updated the question above. –  Richard Whitman Jun 22 '12 at 23:11
add comment

2 Answers

up vote 3 down vote accepted

Well, I can see that this is because your system doesn't have a default route installed, for some reason. Compare your forwarding table with mine:

> show route forwarding-table          
Routing table: default.inet
Internet:
Destination        Type RtRef Next hop           Type Index NhRef Netif
default            user     2 0:13:5f:3:af:8f    ucst   580     5 fe-0/0/0.0
default            perm     0                    rjct    36     1
0.0.0.0/32         perm     0                    dscd    34     1

Notice that default is listed twice for me. One with type ucst and once with rjct and yours only has one line with rjct. That reject is why you're seeing no route to host.

My best guess is that the routing daemon needs to be restarted. You could try deactivating the routing options and commiting, then re-activating it. I also don't think that you need the retain property on the next-hop. It's unnecessary in most normal situations.

A safe way to do this effectively if the unit is remote is to deactivate it and then issue commit confirmed 5. This will automatically roll back the configuration after 5 minutes.

I've also encountered times where I had to reboot the device to get the routing table to settle properly, so if it doesn't work after the above procedure then just try rebooting.

Of course, that is assuming that you didn't typo the next-hop. Since you didn't list it I can't say for certain, but according to your routing table and interface configuration the next-hop should be [REDACTED]. If that doesn't match what you have then there's your problem.

share|improve this answer
    
Deactivating the route and reactivating it worked. Its strange, cuz I tried it before. –  Richard Whitman Jun 22 '12 at 23:53
    
Yeah, I don't know why that happens, but I've seen it come up every once in a while. –  bahamat Jun 22 '12 at 23:55
    
Nobody is pointing out he's trying to route a private network to a public one on a router that doesn't support address translation? –  SpacemanSpiff Jun 23 '12 at 22:41
    
The IP addresses were changed to protect the innocent. –  bahamat Jun 24 '12 at 15:57
add comment

When you are using the routing policy, check if the next-hop is in ARP table.

ps. just guessing, but basically this might be the case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.