Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

How do I apply a MAC Address (of my choice, not random) to a VE (Virtuozzo powered)

I tried this:

[root@node root]# vzctl set VEID# --mac "actual mac address here" --save Invalid usage. Option --ifname not specified

In order to license software for use for my client's company, the vendor needs the MAC Addresses setup for their vps' virtual enet interfaces.

Tried various methods, not working.

[root@node root]# vzctl set VEID# --mac --venet "mac-address" --save Bad parameter for --mac: --venet

[root@node root]# vzctl set VEID# --mac --eth0 "mac-address" --save Bad parameter for --mac: --eth0

[root@node root]# vzctl set VEID# --venet --mac "mac-address" --save VEID#: unrecognized option `--venet'

[root@node root]# vzctl set VEID# --mac "mac-address" --save Invalid usage. Option --ifname not specified

[root@node root]# vzctl set VEID# --mac "mac-address" --venet --save VEID#: unrecognized option `--venet'

Edit/Delete Message

The Virtuozzo NODE uses Centos, as does the VPS container.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

You need the --netif parameter to assign the mac address to the container virtual network adapter

share|improve this answer
    
This is not working either. tinypaste.com/ddc10 –  Clear.Cache Jul 13 '09 at 22:44
    
Yeah, netif needs a value for the network adapter, like eth0 or vznet , thats why the error says netif is ambigous. –  HD. Jul 13 '09 at 23:27

Since you paid for Virtuozzo, I'd suggest asking Parallels for support directly. If you were using the free/open source version, OpenVZ, I'd tell you to use a virtual ethernet device, because the default networking method used does not allow MAC addresses.

share|improve this answer
    
Paid support expired, renewal is a rip-off. –  Clear.Cache Jul 13 '09 at 22:42
    
virtual ethernet device ftw. –  womble Jul 13 '09 at 23:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.