Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to get Python 2.7 working as a CGI script in IIS6. I do this all the time on W2k8, but this is the first time I've tried to use it on IIS6 and I cannot get it to work. Googling suggests just two steps are needed:

  1. Create the Web Service Extension
  2. Add a mapping for .py

I've done both of these but when I try to open a test.py page I get a 404 error. There must be something simple I'm missing. Any suggestions gratefully received while I still have some hair left!

I'm testing on a new install of W2k3R2 so there is nothing extra like URLScan or AV that might be interfering.

I created the Web Service Extension using:

WSE

I'm using Python in a virtual directory, and the directory properties are:

DirectoryProps

And finally the mapping is:

enter image description here

share|improve this question

1 Answer 1

up vote 1 down vote accepted
+100

You can find the additional steps to map your D: Python executable as a CGI, documented on David Wang's MSN Blog

share|improve this answer
    
Hi Mike, I had already seen that article and gone through the steps it described. Anyhow, I thought I'd have one more go, and it worked! I don't know what I did wrong the first time, but anyhow the bounty is yours (in 22 hours when SE allows me to grant it :-) –  John Rennie Jun 26 '12 at 11:31
    
I've set myself an Outlook reminder :-) It appears SE doesn't allow me to award the bonus until 24 hours after I created it, so I'll have to do it tomorrow. –  John Rennie Jun 26 '12 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.