Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've discovered an on-going problem on our Windows Server 2003 domain where some clients are unable to access the UNC path using our root FQDN (we'll call it primary.org). This causes some interesting issues: - I can access our mail server via \mail but not via \mail.primary.org - Logon scripts won't run, because \primary.org\SYSVOL can't be accessed - No server will respond if I try to access via the FQDN - sql.primary.org, web.primary.org etc.

A few months ago we got a new router and changed our IP scheme (figured it was a good time to a project we've been wanting to do for a long time). Everything seems to work, except this DNS issue. I've done quite a bit of Googling, read several threads on Experts Exchange and other tech forums/resources and reading on eventid.net which gave me some ideas, all of which are outlined below.

I've tried re-creating the Reverse DNS entry for primary.org, adding primary.org to a user's HOSTS file (which got me into the network browser, but SYSVOL still locked me out), removing my ISP's DNS servers from the GC DC server, running dcdiag /fix, ipconfig /registerdns, gpupdate /force and replacing the default Group Policy object with a new one. ANY thoughts would be very much appreciated.

Daniel

share|improve this question

2 Answers 2

Try changing HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters to 1 per this KB, or perhaps deleting and re-adding the computer account from AD.

share|improve this answer
    
Thanks, but that KB article is referring to basically the opposite of the problem I'm having and for a Windows 2000 PC. I'm having trouble getting to a UNC share (double backslash - the site stripped the extra one) using the fully qualified domain name (subdomain.domain.org). Ultimately the problem is that Group Policy fails... –  rlmadmin Jul 14 '09 at 16:19
    
It doesn't look like the opposite: "This problem can occur when you try to connect to the server by using a CNAME alias that is created in the DNS zone. For example, this problem may occur with a command similar to the following sample command net view \\alias.domain name.com where alias is a CNAME record that is created for the server in the domain name.com zone. The server is not "listening" on the alias, and therefore is not accepting connections to that name." Also, look further down...it is for Windows 2003 also. –  Adam Brand Jul 14 '09 at 16:34
    
Sorry, to clarify we aren't using CNAME, they should be A records. And the actual domain name doesn't respond (\\primary.org). The servers themselves only respond when using their NETBIOS name (\\mail1). I'll try it and see. It will be a little while before I can reboot the server again though. Unfortunately when we first set up this server we didn't have the resources to have a domain controller separate from our Exchange server, so dropping e-mail for 15 minutes at a time is something we have to do sparingly. :) Thanks! –  rlmadmin Jul 14 '09 at 16:39

You should be able to use UNC names like \\mail\whatever or \\mail.addomain.local\whatever, where "addomain.local" is the Active Directory domain name. I'm assuming here that primary.org is not the AD domain; if it is the AD domain the rest of this post is irrelevant!

If you're trying to use a UNC name with any other name you'll (by default) get an error because W2k3 servers will only respond to SMB requests if the name you're using matches their name. If you want to use some other name you need to turn off the name check on the server. This is described in the KB article http://support.microsoft.com/kb/281308 that Adam mentioned.

JR

share|improve this answer
    
Yes, primary.org (or what we're using in lieu of the real primary domain - I didn't want to be posting our real domain all over the internet - this is the 3rd site I'm posting on for help) is the AD domain. This is a fairly recent issue. \\mail1.primary.org used to work on all systems, and now it doesn't. Thanks. –  rlmadmin Jul 14 '09 at 16:43
    
Hmm, very odd. What does "nslookup mail1.primary.org" return? –  John Rennie Jul 14 '09 at 17:05
    
It works perfectly - returns the following. Server: mail1.primary.org Address: 10.10.125.51 Server: mail1.primary.org Address: 10.10.125.53, 10.10.125.52, 10.10.125.51 –  rlmadmin Jul 14 '09 at 17:35
    
The odd thing is that if I use the HOSTS file to point primary.org to it's IP address I can get to \\primary.org but the SYSVOL still locks me out with the following error: \\primary.org\SYSVOL is not accessible. You might not have permission to access this network resource. Contact the administrator of this server to find out if you have access permissions. Configuration information could not be read from the domain controller, either because the machine is not available, or access has been denied. –  rlmadmin Jul 14 '09 at 17:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.