Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Debian Squeeze server running nginx + php-fpm + fastcgi. I have a typo3 installation on this server which runs well.

No I installed OTRS and I get an error that I do not understand:

2012/06/25 15:35:38 [error] 16510#0: *34 FastCGI sent in stderr: "Access to the script '/opt/otrs/bin/fcgi-bin/index.pl' has been denied (see security.limit_extensions)" while reading response header from upstream, client: ..., server: support.....com, request: "GET /otrs/index.pl HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "support.....com", referrer: "http://support.....com/"

Why do I get this error? The otrs directory is writable for the webserver, so this is not the problem. Any ideas?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

I had a similar problem with index.html files which is how I got here from Google. Among other problems, switching from spawn to php-fpm gave most of my domains "Access denied" errors. I got the same "see security.limit_extensions" in my error.log. The affected index.html files didn't have any PHP code either, but I assume NginX still tried to execute them through php-fpm, thus throwing the errors. I'm using CentOS:

  1. Edit www.conf in the php-fpm.d directory
  2. Edit and uncomment this line, by default .htm and .html are blocked: security.limit_extensions = .php .php3 .php4 .php5 .html .htm
  3. service php-fpm restart
  4. Profit! ;-)
share|improve this answer

OTRS is written in Perl, so you cannot run it through PHP-FPM. That's why you get this error. I suggest reading this article for more information about running OTRS with nginx.

share|improve this answer
    
no, fastcgi is actually running on port 9000 I forgot to mention that. But thanks for the article I go throug it –  ArtWorkAD Jun 25 '12 at 14:21
    
Would you please provide server configuration for your OTRS virtual host. –  Vladimir Blaskov Jun 25 '12 at 17:20
    
the vhost config is quite the same as in your linked article –  ArtWorkAD Jun 26 '12 at 6:18
    
That's not possible - the article uses UNIX socket for communication, while you're obviously using TCP on port 9000. Look, the problem is that a PHP FastCGI manager is listening on port 9000 instead of Perl FastCGI manager. –  Vladimir Blaskov Jun 26 '12 at 6:25
    
Yes your, right. I will check this. –  ArtWorkAD Jun 26 '12 at 6:47

You may try to add to you site's nginx conf file the following sentence in location /: index index.php index.html;

share|improve this answer
    
I don't think setting an index will fix this problem –  Drew Khoury Dec 15 '13 at 20:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.