Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I thought that I had this under control before. But for some reason during our last email marketing promo, I start receiving from our mass email client (built in house)..

The message could not be sent to the SMTP server. The transport error code is 0x800ccc67. The server repsonse was 421 4.3.2 The maximum number of concurrent connections has exceeded a limit, closing transmission channel

again. There's several places I've checked to make sure that wouldn't be an issue. First I checked that receive connector was set to receive an adequate number of connections on our relay connector (1000 connections). Then, I would later find out about Throttling Policies. I created one and set all the properties I knew to set in terms of the policy following properties to 1000; EWSMaxConcurrency, OWAMaxConcurrency, CPAMaxConcurrency, and CPAMaxConcurrency. Still, the email client starts receiving the error shortly after 100 has been sent and takes about 15-30 seconds. The process is then repeatable, but still the error gets received at the same spot everytime.

Is there a rate setting that I am missing? Was there a windows update that I missed looking at? Should the software have it's own throttling feature?

share|improve this question
    
What Exchange role is the server in question? –  Coding Gorilla Jun 25 '12 at 13:56
    
Mailbox, Client Access, and Hub Transport all with Active Directory. –  hydroparadise Jun 25 '12 at 14:14
    
Does "all with Active Directory" mean that it is also a Domain Controller? –  MDMarra Jun 25 '12 at 14:21
    
Yes, primary domain controller. –  hydroparadise Jun 25 '12 at 14:21
    
How is "the email client" sending the mail. Is it just opening 1 connection per recipient without any limits? Also, after you start getting this error message, can the mass mailer continue and retry to send the messages after the errors? –  Coding Gorilla Jun 25 '12 at 14:27

2 Answers 2

Open EMC (Exchange Management Console). Select the Server Configuration node on the nav tree. Then right click the server and select properties. Open the "Limits" tab and configure the section labeled "Connection restrictions". I would recommend increasing the values rather than making them unlimited.

By default the settings are:

Maximum concurrent outbound connections: 1000 *Maximum concurrent outbound connections per domain: 20*

I changed the setting to 5000, 500 respectively.

You will need to restart the Exchange Transport service when finished modifying these settings.

share|improve this answer

Throttling policy is applied to CAS. The server configuration settings are for outbound. You want to manipulate the receive connectors on your Exchange hub transport server which is what is complaining about the traffic it is receiving from your mass mailing app.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.