Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two users experiencing this problem and I've gone through all the possible fixes I can find with no luck. I'm hoping someone has another idea. Here is the info to clarify the problem.

2 users recently got new laptops (Windows 7) and both noticed the problem only after getting the new laptops.

When they remote desktop to any servers on our network, the copy/paste clipboard functionality won't work between the local and remote session, but only sporadically. Sometimes it will actually work.

When using a remote desktop connection to something outside our network, the clipboard functionality works fine.

Here's what I've tried:

  • restarting rdpclip on the remote session
  • checking that the clipboard is selected and local drives are selected in the RDP options under local resources
  • server side is fine as other users have no problem with clipboard functionality on these same servers
  • New laptops for these users are in the same AD organizational unit as the rest of our office

Any Ideas? Any help is greatly appreciated.

Thanks!

share|improve this question
1  
You might encourage more answers if you accepted some of the better answers on your other questions. – EightBitTony Jun 25 '12 at 18:56
1  
Thanks, didn't realize I was supposed to do that – Mike Jun 25 '12 at 19:39
    
@Mike: is the for only clipboard, or also files? If the user right-clicks and attempts to paste some data, is the Paste menu option dimmed, or does it just not do anything when they select Paste? – Greg Askew Jun 25 '12 at 21:33
    
Good point Greg, it doesn't work for files and for text. I will check with the users about the paste option being greyed out. – Mike Jun 26 '12 at 16:53
    
One user now reports that they can copy text, but not files – Mike Jun 26 '12 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.