Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I turn off apc.stat it causes a 500 internal server error. I checked the apache error_log and it's something about:

[Tue Jun 26 10:02:59 2012] [error] [client 127.0.0.1] PHP Warning:  require(): Filename cannot be empty in /var/www/site1/public/index.php on line 17
[Tue Jun 26 10:02:59 2012] [error] [client 127.0.0.1] PHP Fatal error:  require(): Failed opening required '' (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/site1/public/index.php on line 17

I checked that line and here's what it contains:

require('./wp-blog-header.php');

I don't see anything wrong with it. Here's my current APC config:

APC version: 3.1.10 PHP Version: 5.4.4

How do I resolve this error when i disable apc.stat?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I regret I'm gonna have to answer my own question after a few times of google search and bites of doughnut.

https://bugs.php.net/bug.php?id=61854

It's a bug when using relative includes and apc.stat=0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.