Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to be able to use Home, End and Delete keys when using PuTTY to access the CLI on my Cisco ASAs. Currently when I use these keys I see the ~ character.

I have tried changing the PuTTY session Keyboard setting for Home and End from Standard to rxvt - this resulted in Delete giving ~, Home doing nothing at all, and End giving w.

Is it possible to get my keyboard to behave?

I have this all working fine for connections to Linux, but not Cisco devices.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

In the ASA CLI your home, end and delete functions are replaced by:
Ctrl+A home
Ctrl+E end
Ctrl+D delete

share|improve this answer
    
+1 Unfortunately Cisco decided they wanted it broken like this. –  Chris S Jun 28 '12 at 13:34
    
Guess that's the best I'm gonna get. Thanks. –  dunxd Jul 12 '12 at 11:00
add comment

Try to change the "Terminal-type string" value to linux or putty in putty session settings (Connection -> Data -> Terminal-type string).

share|improve this answer
    
Neither option makes any difference when accessing my Cisco devices. I still get ~ for End, Home, and Delete. –  dunxd Jun 27 '12 at 15:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.