Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Exchange 2007 SP3 which is exposing outlook web access over only HTTPS. However the server delivers the sessionid cookie without the secure flag set. Even though I don't have port 80 open, this cookie is still vulnerable to being stolen over port 80 in the event of a man-in-the-middle attack. It also contributes to a PCI-DSS failure

Does anyone know if I can persuade the web server/application to set the secure flag?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Indeed you can. Your question got me curious so I tested it and it works.

In the web.config of the OWA app (which by default lives in \Program Files\Microsoft\Exchange Server\ClientAccess\Owa on the drive where you installed Exchange), set the following in the <system.web> section:

<httpCookies httpOnlyCookies="true" requireSSL="true"/>
share|improve this answer
add comment

I tried this answer and it crashed the application. I found some notes on MS site that said that OWA uses the cookies in scripts and therefore does not support the httpOnly flag.

share|improve this answer
    
This is better as a comment as it is not really an answer. Once you have more reputation, you can post a comment –  Dave M Jun 17 '13 at 15:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.