Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to VNC into an OSX 10.4.11 box from Vista using RealVNC and TightVNC. I can connect successfully, but after a minute or so my VNC window freezes completely, while on the Mac the AppleVncServer process starts eating up huge amounts of RAM (100Mb +) and CPU (40-50%) - but the Mac doesn't freeze. When this happens no-one can VNC in anymore until the AppleVncServer process is restarted.

I have trawled through all the available options on the VNC clients I'm using and I don't see anything obvious that would cause this behaviour. I'd be grateful for any insights into this.

Darko

UPDATE: After more troubleshooting it seems this happens only when I to a copy on Vista. As soon as a copy operation is performed VNC freezes up. Note that copy paste inside VNC works fine....

share|improve this question

closed as off topic by sysadmin1138 Jul 10 '11 at 23:52

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Reflecting back on this, it should probably have been moved to superuser –  Darko Z Jul 29 '11 at 4:17

4 Answers 4

up vote 3 down vote accepted

This is a known issue with clipboard incompatability.

For Example a TightVNC connection configuration file will contain disableclipboard=0. Change that value to 1 and your VNC server on the MAC side will not crash.

share|improve this answer
    
I confirmed Evan's answer - it's the clipboard thing. i'm trying winxp to macosx –  user59553 Nov 8 '10 at 15:44

I've had similar problems in the past with RealVNC and TightVNC.

Have you tried UltraVNC yet? This solved the problem for us. Not sure why.

share|improve this answer
    
thanks i'll give it a go. also troubleshooted some more and updated question –  Darko Z Jul 14 '09 at 2:00
    
sorry mate, Ultra VNC wont even log on. According to UltraVNC no-one uses passwords longer than 8 characters –  Darko Z Jul 14 '09 at 2:07
1  
Very strange. We're using UltraVNC with an 11 character password. –  KPWINC Jul 14 '09 at 2:30
    
+1 for UltraVNC, RealVNC and TightVNC sorely need improvements... –  Avery Payne Aug 15 '09 at 1:06
    
+1. Switching to UltraVNC and turning off the clipboard option fixed this problem for me. UltraVNC looks way better than RealVNC too. –  the_mandrill Jun 28 '11 at 21:48

I had exactly the same problem with Tiger except I was trying to remote in from a Windows XP machine. I tried a variety of different clients, all with exactly the same results.

In the end I just turned off the VNC server included with Mac OS X and installed Vine Server instead. Never had a problem with Vine Server, no matter which client I used on the Windows PC.

http://sourceforge.net/projects/osxvnc/

I should probably mention, when I upgraded to Leopard, I went back to using the included VNC server. It seems to be more stable.

share|improve this answer

Shot in the dark - As you are saying it is to do with file copy, possibly try running vnc viewer as administrator or disable UAC as it could be a permission issue.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.