Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have several machines on Amazon (ec2) of the type c1.xlarge with 8 cpus, running the Amazon AMI.

Details on the machine:

  • 7 GB of memory
  • 20 EC2 Compute Units (8 virtual cores with 2.5 EC2 Compute Units each)
  • 1690 GB of instance storage
  • 64-bit platform
  • I/O Performance: High
  • API name: c1.xlarge

One out of the several machines is showing a high load average, since we have run the last yum upgrade a couple of weeks a go. We did not yet update the other machines, and everything looks normal on them.

The strange thing is that the top command not showing any hint for the cause of the load. CPUs are -

4.8%us, 1.1%sy, 0.0%ni, 94.1%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st.

Mem is about 1.5GB free.

Any idea what could it be, or where else can we check?

iostat command on the proper machine:

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           8.97    0.03    4.46    0.19    0.14   86.23

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
xvdap1            1.60         0.69        55.38     587620   47254184
xvdfp2            2.64         1.10        61.04     934786   52091056
xvdfp4            0.86         0.19        41.72     163866   35601920
xvdfp1            4.37        36.59        73.89   31220810   63051504
xvdfp3            8.03         7.08        94.63    6045402   80749184

iostat command on problematic machine:

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           9.29    0.04    5.55    0.26    0.11   84.74

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
xvdap1            2.13         3.34        68.85     246244    5077888
xvdfp1            7.60        74.31       104.88    5480362    7734840
xvdfp3           13.22        73.67       125.00    5433386    9218600
xvdfp4            1.11         0.76        65.08      55762    4799248
xvdfp2            4.16         3.31        99.17     243818    7313264

Many thanks for the help.

share|improve this question
    
What's the load average on the okay machines and what's the load average on the 'problem' machine. –  EightBitTony Jun 26 '12 at 14:36
    
load average: 1.50, 1.48, 1.50 –  Oz. Jun 26 '12 at 14:51
    
As expected, those are not high. They may be higher than your other servers, but they aren't high. –  EightBitTony Jun 26 '12 at 14:55
    
But the proper machine exactly like problematic machine and the load average is 0.80, Why is not the same? proper machine even more crowded –  Oz. Jun 26 '12 at 15:12
    
When you look at my problematic machine that "iostat" it looks right? –  Oz. Jun 26 '12 at 15:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.