Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Okay, I recently tranfered my Comodo SSL certificate from my previous Bluehost account to my new rackspace cloud server. (LAMP stack)

Basically I just copy pasted the server cert and key and checked to make sure it was properly installed which it was. Now I am running into some issues, occasionally I will hear from people that they are getting an 'Untrusted Connection Error' while others are not getting this error at all.

Recently someone sent me a screen shot of their error and it said: This Certificate is not trusted because no issuer chain was provided.

The browser they noticed this on was safari so I cleared all my history data in safari and opened the site but I am not seeing that error.

Does anyone have any idea how to fix something like this? Thanks!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It's your responsibility as the server to send the full chain, but you've gotten lucky because the intermediates must be some of the ones included in most modern browsers or OSes.

Just put SSLCertificateChainFile with the concatenated PEM-encoded certs in your ssl.conf and you'll be OK. You can get those certs either from your SSL provider, or by browsing with a browser that works and saving the certs from the chain yourself. You can include the root or leave it off, it doesn't matter since the client will complain about trust either if it doesn't have it either way.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.