Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've migrated my Active Directory Certificate services Enterprise CA to a new server (and from Windows 2003 R2 x86 to Windows 2008 R2 x64). I have been having problems with checking the Certificate Revocation Lists, but I've republished the revocation lists from the Root CA and when I run certutil -urlfetch -verify I don't get any errors any more:

Verified Issuance Policies: None
Verified Application Policies: All
Cert is a CA certificate
Leaf certificate revocation check passed
CertUtil: -verify command completed successfully.

But I still get the same errors when I try to start the CA. I get the following pop-up:

Microsoft Active Directory Certificate Services
The system cannot find the file specified. 0x2 (WIN32: 2)

The policy module for a CA is missing or incorrectly registered. To view or change
policy module settings, right-click on the CA, click Properties, and then click the
Policy Module tab.

and I get the following error in the log:

Log Name:      Application
Source:        Microsoft-Windows-CertificationAuthority
Date:          26/06/2012 15:59:45
Event ID:      100
Task Category: None
Level:         Error
Keywords:      Classic
User:          SYSTEM
Active Directory Certificate Services did not start: Could not load or verify the current CA certificate.  Cobbetts LLP Enterprise CA The system cannot find the file specified. 0x80070002 (WIN32: 2).
Event Xml:
<Event xmlns="">
    <Provider Name="Microsoft-Windows-CertificationAuthority" Guid="{6A71D062-9AFE-4F35-AD08-52134F85DFB9}" EventSourceName="CertSvc" />
    <EventID Qualifiers="49754">100</EventID>
    <TimeCreated SystemTime="2012-06-26T14:59:45.000000000Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security UserID="S-1-5-18" />
  <EventData Name="MSG_E_CA_CERT_INVALID">
    <Data Name="CACommonName">Cobbetts LLP Enterprise CA</Data>
    <Data Name="ErrorCode">The system cannot find the file specified. 0x80070002 (WIN32: 2)</Data>

Microsoft have documentation for this error:

But the documentation just talks about the CA chain not verifying, which it now is.

I was wondering if it was some sort of a cached failure, or a cached copy of an incorrect CRL (I migrated the root CA earlier on and had to republish the CRL before certutil would verify properly), so I tried a reboot to flush out the caches.

That didn't change anything.

I've also tried running Certutil as SYSTEM to see if there was a permissions issue and that didn't solve the problem either.

[To run as system: run psexec -i -s cmd.exe from an elevated command prompt and it will launch a command prompt as system. You can run whoami to check.]

share|improve this question

I had the same error. I was using a Hardware Security Module from nCipher. ADCS wasn't able to access its private key. It seems like when starting the ADCS service, it makes some test among those checking the private key. So, I configured my HSM accordingly. Now it works!!!

share|improve this answer
Check also the path to your DB and Logs if The system cannot find the file specified. 0x2 (WIN32: 2). – odi9 Nov 7 '12 at 15:00
up vote 1 down vote accepted

I resolved this issue with Microsoft support, but I didn't really understand what they did to resolve it.

Dug up the Microsoft support notes, in the hope these are useful to someone:

  1. We found CRL in certenroll folder were missing to validate revocation status from root CA.
  2. We copied CRL from Intermediate CA to Issuing Sub-CA but still got error.
  3. As per debug team Engineer we removed and reinstall ADCS roles but it did not helped.
  4. Finally we found under HKLM\system\CurrentControlSet\Services\Certsvc\Configuration registry CertHash had older values for expired certificates.
  5. Removed the older values of hashes and replaced them with (–) signs and started Certificate service.
  6. Certificate Service Started Successfully.
share|improve this answer

This error can occur if you changed the OS SKU. E.g. went from 2003 Enterprise to 2008 R2 Standard edition. You dont mention the SKU along with OS details.

Assuming that was not the case, then to troubleshoot this you will need to gather the following

  1. a procmon ( of the service startup along with
  2. a registry dump HKLM\system\currentcontrolset\certsvc and
  3. a certsvc debug log. "certutil -setreg ca\debug 0xffffffe3" will enable the debug log in %SystemRoot%\Certsrv.log

enable the debug log, start procmon and attempt to start the service. Stop the procmon when service startup fails.

If you share them out somewhere, I can have a look.

share|improve this answer

I ran into a similar issue with a subordinate CA that was upgraded from Windows 2008 R2 to 2012 R2. Fortunately I had just built a new root CA with Server 2012 R2 that I could match up registry settings with. It turned out that some values in the HKLM\system\CurrentControlSet\Services\CertSvc\Configuration\\CSP key of the upgraded computer didn't match up with the 2012 R2 computer. Specifically, "CNGPublicKeyAlgorithm = RSA" was missing, "Provider" needed changed to "Microsoft Software Key Storage Provider" and "ProviderType" need changed from 1 to 0. After making those changes, Certificate Services was able to start without error.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.