Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Windows Server 2008 R2 there is the "Server Manager" program that always starts up when I log on. I would like to make it so that this does not start up every time that I log into the server.

How can I do this?

share|improve this question
up vote 11 down vote accepted

I found this blog post by Alen Siljak which describes how you can keep it from starting when logging on. There are two different methods to solve the problem. The first and most simple is a checkbox in the Server Manager itself. The second involves modifying the registry, which can be used to automate and script the process for a large number of servers.

  1. UI Method - In the "Server Manager" program there is the "Server Summary -> Computer Information" section. At the bottom of the section there is a checkbox "Do not show me this console at logon". Check this box and exit the program and at next log on you will not see the Server Manager.

  2. Registry Method - Go to the registry editor and HKLM\Software\Microsoft\ServerManager and set the variable DoNotOpenServerManagerAtLogon to 1. Then go to another entry at HKCU\Software\Microsoft\ServerManager and set the CheckedUnattendLaunchSetting to 0 (Note that this will only set it for the current user). After logging out and logging back on you should no longer see the server manager.

share|improve this answer
3  
@skeletank This would be like someone going to programmers.se and asking a question about how to get stdio libraries to work in C and posting an answer that says to include stdio.h. Sure it's programming related, but it's so elementary that you'd hope anyone acting in a professional capacity would already know it. We appreciate the effort, but this isn't really a problem that a server admin would struggle with. – MDMarra Jun 26 '12 at 20:24
1  
FWIW the registry method portion of the answer is actually of use to me since I've got a circumstance where several dozen VMs pop up this window unnecessarily and I'm trying to write a script that flips the registry settings for all of them without having to manually click through 40+ checkboxes at a time. – Skeolan Aug 26 '13 at 16:34
1  
In cases where the Server Manager opens with a fault and cannot load the MMC, the checkbox is not available to check. If you don't want to fix the fault, but keep the Server Manager from popping up, then the registry method is a great work around. – user196793 Oct 30 '13 at 19:30
2  
Just checking - did you mean to say CheckedUnattendLauncSetting (with no h) – Doug Jun 12 '15 at 4:10
1  
@Doug You are correct. I've corrected it to be CheckedUnattendLaunchSetting. – skeletank Dec 11 '15 at 20:04

This behavior can also be suppressed with Group Policy. From The Server Manager Main Window on TechNet:

The Do not show me this console at logon check box in the Computer Information section lets administrators prevent Server Manager from opening automatically when they log on to the computer, if they do not need to see Server Manager at every logon. This behavior can also be controlled by the Group Policy setting Local Computer Policy/Computer Configuration/Administrative Templates/System/Server Manager/Do not display Server Manager automatically at logon.

share|improve this answer

On our server, start Server Manager, at top near right pick "Manage", then "Server Manager Properties", and on that screen, check "Do not start Server Manager automatically at logon".

share|improve this answer
    
How is this answer different from the accepted answer? – Katherine Villyard Apr 26 at 20:59

in "Server Manager" window, at the top right menu

(click) Manage > Server Manager Properties
(Window pops up)

(Check) "Do not Start Server Manager Automatically at logon "

(Click Ok)

it's Done!!

note: i tried it on. "Windows Server 2012 R2 Standard - Build 9600".

i wasnt able to find the menu that is mentioned on accepted post. thats why i write it .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.