Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

How I can upgrade Apache 2 from 2.2.17 to 2.2.22 on Debian 6.0 (x86)?

share|improve this question
    
Why do you need to do that? –  Shane Madden Jun 27 '12 at 2:23
2  
Unless 2.2.22 has some new feature you absolutely cannot live without, I recommend you stick with the version the debian apache team deems "stable for a production environment". If you're worried about some kind of security bug in 2.2.17, rest assured that the debian team will have applied a fix, almost certainly well before you first learned about it. –  Shadur Jun 27 '12 at 8:15

3 Answers 3

There is no Apache v2.2.22 in squeeze-backports, so you can install it from debian sid repo at your own extreme risk - package from sid repo can create lot of troubles with unresolvable dependencies.

Add sid repo to your sources.list:

deb http://ftp.debian.org/debian/ sid main contrib non-free

Run

apt-get update && apt-get -t sid install apache2

After installation of apache comment line with sid repo in your sources.list and run apt-get update again.

NOTE: Doing this is highly contraindicated, and any and all subsequent problems with your system are completely your own. It's also very hard to reverse.

share|improve this answer

As others have said, you should only do this when you really need it for something, as it is very easy to mess up your system with this method.

If you still want to do it though, I recommend using the Testing repository, rather than the sid repository, as this repository is usually a little more stable. The way to do this is exactly the same as in hangover's answer, only replace sid with testing. Both repositories have Apache 2.2.22.

Again, you should not do this unless you really need it. I have made that mistake before. And do not forget to remove the testing repository afterwards, or set up apt pinning.

As a sidenote, if you want the rest of your webserver up-to-date, I can recommend the dotdeb repository for that.

share|improve this answer

If possible, you can do a dist-upgrade to wheezy, which should upgrade your version to 2.2.22.

I'm having the same issue right now, and since these are production boxes I'm nervous about the downtime of doing a full upgrade, so I'm thinking of using Shadur's sid repo solution; of course, I'll be testing in my dev environment first to ensure there are no issues with it.

Additionally, in response to the comments about why someone would want to do this upgrade, there are security vulnerabilities in versions 1.3.x, 2.0.x-2.0.64, and 2.2.x:

http://www.acunetix.com/vulnerabilities/apache-httpd-remote-denia/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.