Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

has anyone got experience of setting up ftp on bitanmi's amazon linux?

I have followed the instructions, configured both firewalls set up vsftpd, but am having no luck with connecting.

Any one have any idea what is going on?

share|improve this question
    
You need to allow all TCP ports on the console security firewall, and then you need to allow port 21/tcp via iptables on your AMI shell. –  Andrew Smith Jun 27 '12 at 13:05
    
Like I said, I have done all that. –  Andy Jun 30 '12 at 19:10
    
I have several years experience configuring and setting up servers. There is definitely something else going on. More to the point, why would anybody offering an off the self application/stack combo not make this blinding simple - rather than absurdly complex. –  Andy Jun 30 '12 at 19:12
    
Doh, I'll take that back was blinding simple, for reference the standard set up for vsftpd is set up only to listen on 127.0.0.1 –  Andy Jun 30 '12 at 19:27

1 Answer 1

By default FTP is not enabled for remote connections. If you want to use a FTP program like Filezilla or WinSCP you need to configure the connection through SSH (sFTP). It is necessary to specify your private key. You can find more info at http://wiki.bitnami.org/BitNami_Cloud_Hosting/Servers/Access_your_machine#Uploading_files

There is also a FTP running in the machine itself. This is used to download files from the applications. It is configured to listen only on 127.0.0.1. If you want to enable it, you have to open the 21 port in the Amazon firewall and remove the "listen_address" option from the /etc/vsftpd.conf file and restart it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.