Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a new Windows 7 machine named PAP44 in the PAP workgroup. The networking is set to "Work" mode for the wired LAN.

I have a couple of users and I've shared a folder and set it so both users can read/write. Confusingly for me, rather than sharing just that folder (as I'm used to with older versions of Windows) it appears to be sharing a path (\\pap44\users\...\myFolder)

From another machine on the LAN, running XP, when I go to \\PAP44\Users I'm asked for a username and password, but neither of the usernames+passwords work. It just jumps back to the username and password dialogue, except that the username I entered gets prefixed with PAP44\

My end goal is to get my Debian/Ubuntu machines to be able to access this share, but first of all I thought I'd try to get it working in Windows, after all, that's supposed to be easy!

Is there another step? (PS. I am not a "hit and run" case!)

share|improve this question
    
What happens if you hit the full share path and not just \\pap44\users? –  Nixphoe Jun 27 '12 at 15:07
    
Same problem. Also, I've just tried "Advanced Sharing" (aka how it used to work) that creates a direct share to the folder, as in \\pap44\myFolder and this has the same issues. –  artfulrobot Jun 27 '12 at 15:08
    
@artfulrobot, Is the share everyone read-write or user read-write? I believe that you need everyone read-write in addition to disabling file sharing password protection for the XP machine to access the share. That is the only way I have done shares in situations similar to this. –  Somantra Jun 27 '12 at 17:34
    
@Somantra yes, it is. But I think the problem with that is that it won't let me turn off password protection. I click No passwords, click Apply, window goes away. Open up the advanced blah blah window again, and the option is re-set to Passwords! –  artfulrobot Jun 28 '12 at 11:24
    
@artfulrobot, dare I ask if it is Windows 7 Home Premium? I can't even ask without rolling my eyes ;-) –  Somantra Jun 28 '12 at 12:15
show 2 more comments

2 Answers

Make sure you're using credentials for an account which is created on Windows 7. Also I would check NTFS permissions for that shared folder on the Security tab.

Otherwise you can try to disable pwd prompt to check if the issue is credentials-related.

Open "Control Panel > Open "Network & Sharing Centre > Select "Advanced Sharing settings > Expand "Home / Work Network > Scroll to "Password protection > Select "Turn Off Password Protect Sharing.

share|improve this answer
    
Thanks for your time. Yep, I'm using the credentials I set up on the W7 machine. The NTFS permissions are open for all users. I disabled passwords as suggested and it now says "Logon failure: the user has not been granted the requested logon type at this computer." –  artfulrobot Jun 27 '12 at 15:00
    
Actually, I did disable passwords, pressed Save, the dialog went away, but re-opening it shows that passwords are still enabled! Doesn't seem to like me turning them off. [Sigh] in a world without walls, who needs windows?! –  artfulrobot Jun 27 '12 at 15:52
    
Hmm, I suppose you should try changing this setting via registry: Run type "regedit.exe", then go here: HKLM\System\CurrentControlSet\Control\Lsa\limitblankpassworduse and change from "1" to "0". –  Volodymyr Jun 27 '12 at 17:20
    
Thanks for tip. All this registry voodoo makes me nervous - difficult to maintain (I have 4 of these to set up!). I'll try that soon. –  artfulrobot Jun 28 '12 at 11:25
add comment

As @inhabitant already mentioned, the short answer is you need to disable file sharing password protection on the Windows 7 machine.

Here is a good link on the topic.

http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/a25bb8f4-fa03-436c-9c33-6c90c7b0723f

Relevant Excerpt:

When you mark a share as Everyone read/write, the Windows 7 system still requires authentication from every connection. When that fails the connection is rejected.

As soon as you disable file sharing password protection, you enable Guest access. This enables access to the share without authentication. This will allow access to the system from an XP machine.

By default the authentication from XP is not compatible with Windows 7, that's why you can only access the share without authentication.

If you want to use an SMB share between various MS OS and Linux, I would suggest looking at setting up a SAMBA share.

share|improve this answer
    
(sorry if this is a daft question:) When you say look at setting up a Samba share, do you mean on a linux server? I can do this, but there's a specific use-case (Quickbooks) that sort-of requires me to have data on the W7 machine. I want my Debian server to be able to access these files so that I can back them up. –  artfulrobot Jun 27 '12 at 15:46
    
Yes, on a Linux server. I would say that with my limited understanding of your use-case, the simplest solution is Dropbox. It is very good on Linux and Windows. Google Drive has a Linux version too, but it is a lot younger than Dropbox. The LAN-Sync is a nice feature and you have access to previous revisions of every file if you have the Pat-Rack option. dropbox.com/help/11/en And perhaps most importantly you can bypass Windows-Permission hell and greatly simplify access control, if you're into that sort of thing. –  Somantra Jun 27 '12 at 15:58
    
thanks. I only buy Windows PCs if specific software requires it these days. Such a headache. –  artfulrobot Jun 27 '12 at 16:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.