Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My system is Windows 7 x86. Im going to install Apache 2.4.2 VC10 from Apache Lounge and it requires Visual C++ 2010:

Be sure that you have installed the Visual C++ 2010 SP1 Redistributable Package x86.

While PHP 5.4.4 VC9 x86 Thread Safe (as stated on PHP for Windows page) requires Visual C++ 2008:

The VC9 versions require you to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed.

Seems i have to install both. Can PHP work only with Visual C++ 2010 SP1?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The page you are referring to (Apache Lounge) clearly says that it will work:

Note: a VC10 binary loads VC10 and VC9 modules.

...

Works with the PHP 5.4, 5.3 and 5.2 handlers (php5apache2_4.dll) below and the binaries from windows.php.net

share|improve this answer

As opposite to what ApacheLounge tells, it seems necessary to install both Visual C++ 2008 SP1 (for PHP VC9) and Visual C++ 2010 SP1 (For Apache VC10).

Then, it works like a charm, but without doing this, there is a 'side-by-side' problem loading the PHP module. But I admit I wonder if it would not just be better to run all 'suite' using VC9, instead of mixing VC9/VC10.

share|improve this answer
    
Because Apache Lounge does not seem to provide a VC9 version of FastCGI –  Reuben Oct 14 '13 at 4:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.