Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Tmux session running locally, in one of the panes I ssh to another host, however once the remote machine is logged in, the cursor is overwriting the command prompt. I think this is happening because the prompt is different widths on the local and remote machine, e.g:

Local:

 foo>

Remote:

[foo@dev-host-app00 ~]$ 

So in the above example the cursor is flashing over the @ sign and overwriting past it as I type. It seems to think that the prompt with on the remote machine is same width as on the local machie. Can someone please point me at what I might need to do to resolve this?

Thanks in advance.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I think I have found the answer thanks to a colleague. Posting here in case it helps someone else:

On the remote side, TERM was being set to 'TERM=screen-xterm256' which was not recognised on the remote side since this setting is specific to tmux.

Launching the pane as follows solved the issue:

TERM=xterm ssh user@remote
share|improve this answer
1  
Please mark this as accepted so it doesn't show up in the list of unanswered questions :-) –  Mike Pennington Jul 7 '12 at 12:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.