Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having this issue where when I try to use sudo to rcp some files from a Linux host to an HP-UX host (note that the destination directory requires root access to write to), I get the following error from HP-UX's side:

remshd: Login incorrect.

I should note that the passwords for the Linux host and the HP-UX host are different. The command doesn't seem to give me a chance to enter the proper HP-UX password and automatically defaults to this error.

share|improve this question
    
Is root login disabled? Can you login as root locally (i.e., as a login shell), or ssh from root to root? –  Andrew M. Jun 28 '12 at 0:18
    
Please do not cross post. Server Fault is the correct place for this question. –  Mark Henderson Jun 28 '12 at 3:27

1 Answer 1

The rcp man page says

Rcp does not prompt for passwords; it uses Kerberos authentication ...

You'll probably find it easier to use scp to do this. If you allow root logins via ssh on ypor HPUX system then

scp -r /local/path root@hpux.tld:/remote/path

should do the trick. If you don't allow root logins then login to the HPUX host and obtain a root shell then

scp -r user@linux.tld:/remote/path /local/path 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.