Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I use screen command, I am not able to use page-up and only 1 page is displayed on the screen. If I do not use "screen" command, I can scroll up a few pages.

1) How do I enable scrolling while using screen command.

2) While not using screen command, there are only about 10 screens I can view. How do I increase this limit?

share|improve this question
Right now, I use the scroll wheel on my mouse to scroll up. When I type in the "scroll" command, it returns a Google query on the word "screen." What OS and shell or application you're trying to use might be useful information here. For example, the scroll wheel doesn't work when I'm navigating through the AS400 <shudder>, or staring at prompt on ESX. :/ –  HopelessN00b Jun 28 '12 at 3:45

2 Answers 2

up vote 5 down vote accepted

In GNU Screen, press Ctrl-a, Esc to enter copy mode, then you can use standard navigation keys to navigate around: hjkl, as well as Ctrl-f (page forward) and Ctrl-b (page back).

As far as increasing your terminal's scrollback buffer, that's completely dependent on what terminal you're using. If you poke around in the settings, you're sure to find it. These applications aren't all that complex.

share|improve this answer
# Thanks # But when I type a new command do I have to type Ctrl - a, Esc again to scroll up in screen mode? –  shantanuo Jun 28 '12 at 4:01
@shantanuo - honestly, this is all very well-documented elsewhere. It just sounds like you don't fully understand how Screen works, so you probably ought to just go through one of the many beginner's tutorials out there. –  EEAA Jun 28 '12 at 4:07
termcapinfo xterm|xterms|xs|rxvt ti@:te@ ## solved by adding this to ~/.screenrc –  shantanuo Jun 28 '12 at 5:00

I assume that you are using PuTTY as a terminal client. To increase the scrollback of PuTTY, change: Category/Window/Control the scrollback in the window/Lines of scrollback to 5000. Note that this will increase the PuTTY memory foot print a little bit.

For screen, I am using CTRL-a [ then PG_UP and PG_DOWN to scroll. To exit this mode press ESC.

share|improve this answer
Might those be custom screen keybindings? They weren't working for me... –  EEAA Jun 28 '12 at 3:51
Sorry, it was a typo. It is C-a,[ not C-[. –  Mircea Vutcovici Jun 28 '12 at 4:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.