Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to configure my WCF services under WIndows Server 2008 R2's IIS and AppFabric to auto-start, but the steps listed at MSDN are possible only when the services reside in an application, but in my case, the .svc files reside directly in the site root.

This way, the 'Configure WCF and WF...' shows as '...for Site' and do not show the options for auto-start, as it would do if the application were hosted under an application sub-folder.

Does someone know what I'm doing wrong?

share|improve this question
up vote 2 down vote accepted

It is answered over here on MSDN, the one from SilverNinja is a better answer.

I found that the IIS UI is not that great for configuring applications - especially when trying to setup the Site Root as an autostart application. The best way to manage it is by using the Configuration Editor that comes with AppFabric under the Computer Name -> Management of Features View.

To make a Site Root an autostart application - you need to locate the Section system.applicationHost/sites and click the (Collection) entry. Click on your site name in the list of sites and click (Collection) once more. Select the application in the list and assign the serviceAutoStart="True", serviceAutoStartMode="All", and serviceAutoStartProvider="Service". Also enter net.pipe for the enabledProtocols ("http, net.pipe").

You also need to change the application pool setting to AlwaysRunning. To locate this setting, use the Collection Editor to navigate to the Section system.applicationHost/applicationPools. Click the (Collection) value and then select the application pool used by your root site and assign startMode="AlwaysRunning".

At this point, you can script your changes via "Generate Script" or apply them immediately using the "Apply" action. Hopefully this helps someone else who was as confused as I was about the issue. To test the configuration, you can issue an iisreset to see if your w3wp.exe process starts immediately.

Autostart Configuration MSDN Reference

share|improve this answer
Welcome to Server Fault! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Scott Pack Aug 23 '12 at 18:12
HopelessN00b, thanks for fixing my answer. Scott Pack, I'll keep that in mind. – SmallBizGuy Aug 28 '12 at 17:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.