Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I know this questions has been beat to death, but I've read almost all the responses and it hasn't solved my issue. I installed APC (no noted errors), I told PHP.ini to enable it and I made sure I am running PHP in FastCGI with SuExec turned off.

Still I have no go.

PHP / suEXEC Configuration

  • Default PHP Version (.php files) 5
  • PHP 5 Handler fcgi
  • PHP 4 Handler none
  • Apache suEXEC off
  • Apache Ruid2 off

php.ini Configuration

Alternative PHP Cache apc.enabled
Alternative PHP Cache apc.shm_segments
Alternative PHP Cache apc.shm_size

When I run the APC.php file I get this message:

No cache info available. APC does not appear to be running.

share|improve this question
add comment

1 Answer

I ended up finding the answer after much more searching. The problem exists when the apc.so file does not exist in the module_dir specified in the PHP.ini file.

Long story short, you can either change the directory or just move the apc.so file from it's directory to the one specified in PHP.ini file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.