Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been working on a setup that includes Windows 2008, IIS 7.5 with isapi (for redirect) and Tomcat 6.0.32. The issue I have is when I go to the URL that should display the tomcat service I get a 404 error.

So I should mention that this is a clone of another VM in a VMware environment. The original machine already had this setup working and it still works. This machine however never worked after cloning. I did make some changes to the networking and the computer name.

I have review various documents and compared the settings to the original machine and can not find any issues.

One specific item is that if I run -> tasklist /m is* on the nonworking clone I get:

Image Name                     PID Modules
========================= ======== ============================================
inetinfo.exe                  1288 ISATQ.dll, iscomlog.dll
w3wp.exe                      3136 isapi.dll

On the working server, after I attempt to access the tomcat application through the application, I see:

Image Name                     PID Modules
========================= ======== ============================================
inetinfo.exe                  1168 ISATQ.dll, iscomlog.dll
w3wp.exe                      7604 isapi.dll
**w3wp.exe                      9912 isapi.dll, isapi_redirect.dll**

NOTE: I think there is some issue with the isapi_redirect.dll

I am able to access the application by going to the IP and port - 10.0.0.10:8080

Does anyone have any thoughts?

share|improve this question
    
If you look at the W3SVC logs, you should be able to see the request coming in and compare that with the bindings you have configured for the site in IIS. Also checkout the substatus code, that should be very helpful in identifying the root cause. pulsitemeter.com/700r4/404-Substatus.html –  Somantra Jun 28 '12 at 16:25
    
And is the 404 from Tomcat or IIS? That is an important detail. –  Somantra Jun 28 '12 at 16:26
    
Looking at the link - support.microsoft.com/kb/943891 I found that the information in the log corresponds to - Not Found. Here is the log: #Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken 2012-06-28 18:07:44 192.168.103.109 GET /merchant/ - 80 - 192.168.103.49 Mozilla/5.0+(Windows+NT+6.1;+WOW64)+AppleWebKit/536.5+(KHTML,+like+Gecko)+Chrome‌​/19.0.1084.52+Safari/536.5 404 0 2 203 –  imthefirestartr Jun 28 '12 at 18:12
    
so do you have a binding configured in IIS that matches 192.168.103.49? Try NETSTAT -NOAB and see if you have anything listening on that socket on the IIS machine. You can also find site bindings in IIS Manager | Connections | Sites | <your site> | Action pane > Click Bindings. –  Somantra Jun 28 '12 at 19:29
    
After further inspection, that log entry shows CLASS C addresses only and you say it is on a CLASS A? It also shows port 80, so that has me scratching my head. –  Somantra Jun 28 '12 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.