Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As soon as i open a phpinfo() script called version.php apache stops working. Here is the error.log file. My configuration (my local development machine):

PATH environment variable is PATH=C:\WAMP\Apache\bin;C:\WAMP\PHP and installation folders (unzipping) are:

  • C:/WAMP/Apache
  • C:/WAMP/PHP

Microsoft Visual C++ 2010 SP1 x86/x64 installed and updated. So everything looks fine to me. PHP integration in httpd.conf is:

# Integrazione PHP
LoadModule php5_module "C:/WAMP/PHP/php5apache2_4.dll"
PhpIniDir "C:/WAMP/PHP"
AddType application/x-httpd-php .php

<IfModule dir_module>
    DirectoryIndex index.html index.php
</IfModule>
share|improve this question
add comment

2 Answers

I've seen PHP crash Apache on phpinfo() before when:

  1. I was using PHP as a FCGID process and it was not configured right.
  2. I was using one of the opcode caches such as APC.

Try removing the loaded PHP modules/extensions one-by-one to see if one of them is causing this.

share|improve this answer
add comment

I don't assume that PHP uses the PATH variable to resolve the path of the extensions. So try adding the whol path in the extension_dir variable like

extension_dir = C:/WAMP/PHP/ext
share|improve this answer
    
Actually i found that Apache is crashing as soon as i run a script. I changed the whole question. Thanks for helping. –  user34295 Jun 29 '12 at 15:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.