Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS 5.5 VPS server.

I want to use RVM.

According to the console output when I run the RVM installer, RVM requires bash >= 4.1.

I just ran yum update. My bash version is now 3.2.25.

If I understand how yum works, that means that 3.2.25 is sort of the version of bash that "belongs with" my CentOS version, and it's the latest version I can get using yum. (Right? Or am I wrong about this?)

How can I get that on my CentOS 5.5 system?

To clarify, I understand that I can just download the source and install, but I'm hesitant to break out of yum's version management system. Is there a way to upgrade bash without disrupting yum?

share|improve this question
    
$ \curl -#L https://get.rvm.io | bash -s stable --autolibs=3 --ruby ---> BASH 3.2.25 required –  ohho May 9 '13 at 9:37

1 Answer 1

up vote 6 down vote accepted

Not directly. Grab the SRPM from Fedora and rebuild using mock. Note that this will not quite work with yum since you'll have to handle updates yourself by repeating the procedure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.