Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS 5 web server which currently mounts a NFS export on my Mac OS X 10.7 laptop. It works great, except over VPN I can't get it to mount at all. I tried SMBUp but haven't been able to get it working even locally. It doesn't look like there's an easy way to install netatalk for CentOS 5. Even still, I'm not sure if that's the best way to do it.

I tried using a GUI SSH client that can "mount a FTP disk" and it would work, except the files require root access and there's no external root access and the client can't elevate permissions.

The basic thing I need to do is have the server be able to read the files off of my laptop, connected via VPN. The files are frequently updated (every 5-20 seconds) so I don't want to manually do that via SSH.

Which protocol can work with both platforms and easily handle the latency introduced by VPN (and potentially mobile broadband)?

Thanks

share|improve this question
add comment

1 Answer

There are several routes to go here. I'd personally go with SSHFS and set whatever rights you need - either through group membership or an ACL - to avoid needing to run with elevated rights.

share|improve this answer
    
I'm currently playing with SSHFS. I've got it installed on the server. I can SSH in from the server to my Mac (remote login is enabled.) Currently trying to mount a specific directory on the Mac, on the linux VM. But when I try that, I get FATAL: Module fuse not found. I followed this centos.org/modules/newbb/viewtopic.php?topic_id=14292 Any tips on using SSHFS on a CentOS 5.3 box to mount a directory on OS X? –  user1337 Jul 2 '12 at 21:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.