Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a freenas NAS with a SMB share running at 192.168.2.2 of a 192.168.2.0/28 network. Gateway is 192.168.2.1. Originally this was running on a switch with my LAN, but now having upgraded to new hardware the Freenas has it's own port on the firewall. Before the switch the freenas would show up under Network on a windows 7 box and an OSX Lion box as freenas{wins} or CIFS shares on freenas{osx} so I know it doesn't have anything do to with the freenas. Here are my pfsense rules.

ID  Proto        Source     Port    Destination     Port    Gateway     Queue   Schedule    Description     

PASS    TCP     FREENAS net     *   LAN net         139 (NetBIOS-SSN)   *   none        cifs lan passthrough    

PASS    TCP     FREENAS net     *   LAN net         389 (LDAP)          *   none        cifs lan passthrough    

PASS    TCP     FREENAS net     *   LAN net         445 (MS DS)         *   none        cifs lan passthrough    

PASS    UDP     FREENAS net     *   LAN net         137 (NetBIOS-NS)    *   none        cifs lan passthrough    

PASS    UDP     FREENAS net     *   LAN net         138 (NetBIOS-DGM)   *   none        cifs lan passthrough    

BLOCK   *   FREENAS net         *   LAN net         *                   *   none        

BLOCK   *   FREENAS net         *   OPTZONE net     *                   *   none            

BLOCK   *   FREENAS net         *   192.168.2.1     *                   *   none            

PASS    *   FREENAS net         *   *               *                   *   none                

BLOCK   *         *             *   *               *                   *   none    

I can connect if I use \\192.168.2.2 and enter the correct login details. I would just like this to show up on the network. Nothing in the log seems to be blocked when I filter by 192.168.2.2.

What port am I missing for SMB to show up under the network and not have to connect by IP?

ps. Do I really need the LDAP rule?

__________________Update________________________

Almost there

Enabled "Register DHCP leases in DNS forwarder" and "Register DHCP static mappings in DNS forwarder" So now from my windows machine I can type \\freenas and get to correct share.

The problem is I have WDtv and if I want to connect to the freenas share it must show up under the "Network" portion of my windows computer, ie Network Discovery MUST be working.

Does anyone know how to solve this issue?

share|improve this question
    
Is the pfsense device your new "firewall?" I think we need more details on how this is all hooked together –  Joel E Salas Jul 3 '12 at 3:54
    
May just be a DNS issue. Have you checked the DNS Forwarder page in pfSense (and possibly added an entry in the Hosts Override section)? –  charlesbridge Jul 3 '12 at 11:18

2 Answers 2

Ports don't have any relation to network browsing in this case. Cross-subnet browsing in general is problematic, if you search related to Windows cross-subnet browsing you'll find information. It's just a general Windows browsing issue, your firewall ruleset you're showing there is good.

share|improve this answer

Building off of what @Chris Buechler said, cross subnet broadcast based discovery typically doesn't work. The exceptions are using ip helper declarations to pass specific types of traffic across subnets.

If the SMB share and the clients are on the same 192.168.2.0/28 what you probably need to do is bridge the the interface going to the SMB share with the interface going to the switch. This will make the two ports interact on layer 2 effectively using pfsense to do switching.

Given what you've said if the primary users for the share are on the 192.168.2.0/28 network overall performance will be better if the server is running off the switch closer to the users. Your current setup will place more stress on the connection from pfSense to the switch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.