Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a weird problem in my samba 3.5.4 share on Ubuntu 10.10. I have one share definition for 3 client (A,B,C) This share contain some excel file which having a lot of formula and linked each other. Client A accesses the file with libre office (ubuntu), client B access with WinXP & MS Office 2003, The write and read process working successfuly on Both of them.

The problem occurs when client C accesses the same file with MS Excel 2003 (windows xp). This message box appears when he saves the file:

Microsoft office excel cannot access the \\\myshare\
There are several possible reasons: 

     - The File ort path does not exist The file is being used by another program. 
     - The workbook you are trying to save has the same name as a
     - Currently open workbooks.

I have tried the solution presented in KB291204, but it didn't work. Below is my share definition :

comment = brainshare
path = /opt/brainshare/
valid users = @brainshare
force group = brainshare
read only = No
create mask = 0775
veto files = /*.scr/*.eml/

How can I troubleshoot this problem?

share|improve this question
up vote 0 down vote accepted

Problem solved. The solution came from

 Add this line to your share definition :
 # On 3 July 2012 13:11, Daniel Müller <> wrote:
     directory mask=2770
     force directory mode=2770
     create mask = 2770
     force create mode=2770
     force security mode=2770
     force directory security mode=2770
     force group= yourgroup
 # Give the directory the sticky bit for the group
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.