Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up an Exchange 2010 SP2 for a customer.

However, the server address that the server returns with autodiscover is wrong, as it points to the internal domain (.local) - and not the external address.

How do I change this?

Here's an image to describe what I mean:

Image to describe it
It is the upper field that is wrong.

I dont want users to enable the RPC over HTTP-thing, as the users know barely nothing about computers.

Thank you in advance.

share|improve this question
    
Please explain what you mean by "the server address that the server returns with autodiscover is wrong." In what client program are you seeing this address? –  HopelessN00b Jul 3 '12 at 13:55

2 Answers 2

You should be able to change all of this using the Exchange Shell but I did a quick search and came across this PowerShell Script which may take some of the pain out of it. I have not tested or used it but it looks like it calls all of the right things.

share|improve this answer
    
Thanks for your reply, I will try to look at that script. –  Frederik Nielsen Jul 3 '12 at 13:02
    
Allright, looked a bit into it, ran it, and setup both internal and external URL's to be the same (the external FQDN). However - this hasn't helped at all. Outlook still tries to connect to the local address, which cant be done as it doesnt exist on the remote machine. –  Frederik Nielsen Jul 3 '12 at 13:15
    
Your internal address SHOULD be your internal FQDN for your domain: mail.mydomain.local. Unless your domain is a public domain, which from your screenshot it is not, this should never be a public FQDN. Only the external name should be. I'm a little confused when you say "cant be done as it doesnt exist on the remote machine" what does that mean? –  Brent Pabst Jul 3 '12 at 13:19
    
What I mean is, that the machine connecting to the exchange server has no idea where to find exchange.server.local - as they are not in the same physical location, and are not going to be. –  Frederik Nielsen Jul 3 '12 at 13:26
    
@FrederikNielsen Hmm, once you update the external URLs the autodiscover service should start returning that URL, try restarting the Autodiscover service to see if it updates. You can also use testexchangeconnectivity.com to verify the autodiscover settings. –  Brent Pabst Jul 3 '12 at 13:29
up vote 1 down vote accepted

Fixed it.

First, I created a CAS array, with the one server as member (sounds ridiculous to me, but it worked).

Then I changed the mailbox's rpc cas server address with help from this link

Finally, I noticed that I needed to open port 28755 and port 6008 in the firewall for it all to work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.