Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My problem is totally opposite with this member. For my case, I cannot login to mssql 2008 without specify the instance name. I am thinking how to connect to mssql by just having the server name. This is because the application I used does not allow symbol like (MSSQL\MYDB). Please further asking if I am not giving enough information.

Solved: By setting server roles "sysadmin", then the problem is being solved. Documentation of the application mentioned that as long as fill in the server name and also port number, the installation can automatically resolves the instance name from provided port. Appreciate for any reply.

share|improve this question
    
You should chase up that application vendor and ask for SQL named instance support. –  MichelZ Jul 3 '12 at 16:34
add comment

4 Answers

If you have a named instance the alternative format for the connection string would generally be "server,port". You spoils need to look at the software manual to verify.

share|improve this answer
    
unluckily no comma allowed also since it is a symbol also. sigh... –  SƲmmēr Aƥ Jul 3 '12 at 15:24
add comment

You would have to install SQL Server as a "default" instance.

An instance is either the default, unnamed instance, or it is a named instance. When SQL Server 2005 is in installed in the default instance, it does not require a client to specify the name of the instance to make a connection. The client only has to know the server name.

A named instance is identified by the network name of the computer plus the instance name that you specify during installation. The client must specify both the server name and the instance name when connecting.

http://msdn.microsoft.com/en-us/library/ms165614(SQL.90).aspx

share|improve this answer
    
Is it possible to revoke the instance and make it back to default? Or I have no choice but to reinstall the mssql 2008? –  SƲmmēr Aƥ Jul 3 '12 at 15:23
    
hi Michelz, I wondering why after I specified the instance name during the installation of mssql 2008, then I am not able to connect to mssql by just having the server name. –  SƲmmēr Aƥ Jul 3 '12 at 15:46
    
This is by design. Please read the related article. You will have to re-install SQL Server and choose the "default" instance instead of a named instance, then you will be able to connect by just specifying the server name. –  MichelZ Jul 3 '12 at 16:32
add comment

If your client program runs on Windows, you may be able to specify a "server alias" which allows you to create a simple name/alias on a client computer that "points to" a particular server and instance name. Microsoft provides detailed instructions here.

You should also complain to your software vendor. Microsoft has provided the named instances feature for at least 12 years. Your software should support it.

share|improve this answer
1  
+1 for the vendor knowing how to support a connection string properly! This is basic stuff, I would seriously consider a different vendor! –  Brent Pabst Jul 3 '12 at 14:00
    
have no choice but to make change again in order to establish the connection. because I am just an employee. @@ –  SƲmmēr Aƥ Jul 3 '12 at 15:22
add comment
up vote 0 down vote accepted

Solved: By setting server roles "sysadmin", then the problem is being solved. Documentation of the application mentioned that as long as fill in the server name and also port number, the installation can automatically resolves the instance name from provided port. Appreciate for any reply.

share|improve this answer
1  
Server roles have nothing to do with connection information and requiring an admin-level login is a red flag for bad software. There is an old Dilbert cartoon with the punchline "Our target market is people who are too embarrassed to return the software." If you don't complain nothing ever gets fixed, no one (but you) realizes that there is a problem and the DBA always seems to shoulder the blame for other people's mistakes. Just a friendly warning to the new ("accidental" or not) DBAs out there. –  darin strait Jul 5 '12 at 11:35
    
Appreciate. I will take note on your advise. Thank you very much. –  SƲmmēr Aƥ Jul 6 '12 at 0:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.