Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with the Windows Server 2008 guest (hvm). I can't get a network interface running for him.

I also have a Debian guest and it's working ok, but I can't do it with the Win2k8 guest. When I started the VM, the machine freezes and I can't connect by ssh to the host.

/etc/network/interfaces

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 188.165.B.C
        netmask 255.255.255.0
        network 188.165.B.0
        broadcast 188.165.255.255
        gateway 188.165.B.254

brctl show

bridge name bridge id       STP enabled interfaces
eth0        8000.e840f20acc28   no      peth0

/etc/xen/xend-config.sxp

...
(vif-script vif-bridge)
(network-script 'network-bridge') 
...

/etc/xen/win2k8.cfg

#  Networking
#
vif         = [ 'ip=5.39.F.G,mac=yy:yy:yy:yy:yy:yy,type=ioemu,bridge=eth0' ]

/etc/xen/debian.cfg

#  Networking
#
vif         = [ 'ip=178.33.D.E,mac=xx:xx:xx:xx:xx:xx' ]

As you can see, in the Debian guest I only have to specify an IP address and a MAC. But if I put that in the Win2k8 guest, the machine does not start.

I am using Xen 4.0

share|improve this question
    
I finally fixed it by creating a "manual" bridge in /etc/network/interfaces instead of let XEN to do it –  JavierMartinez Jul 3 '12 at 15:28

1 Answer 1

up vote 0 down vote accepted

I am surprised to see "peth0" in your btctl show output. Perhaps your issue is a simple typo? (but then no idea how your Debian VM should work)

And in my only Debian based system I have right now with a bridge (A proxmox 2.1 machine), I also have the bridge in /etc/network/interfaces:

# cat /etc/network/interfaces
[...]
iface eth0 inet manual

iface eth1 inet manual

iface eth2 inet manual

iface eth3 inet manual

auto vmbr0
iface vmbr0 inet static
    address  10.11.12.13
    netmask  255.255.0.0
    gateway  10.11.0.1
    bridge_ports eth0 eth1 eth2 eth3
    bridge_stp off
    bridge_fd 0
[...]


# brctl show
bridge name     bridge id               STP enabled     interfaces
vmbr0           8000.0025903b7d66       no              eth0
                                                        eth1
                                                        eth2
                                                        eth3
                                                        tap100i0
share|improve this answer
    
peth0 is created by default by Xen. My /etc/network/interfaces does not have a bridge created, as you can see. It is being created by xen when a VM is created –  JavierMartinez Jul 3 '12 at 14:36
    
And with Debian guest everything works fine. It's just with HVM Win2k8. I don't know why but it does not create a right bridged interface –  JavierMartinez Jul 3 '12 at 14:38
    
Just one more thing, eth1, eth2 and eth3 are for failover ips? Because I have it for that, but I do not add them to the bridge –  JavierMartinez Jul 3 '12 at 18:55
    
My system is strange and explaining it would be out of context... but here it is. My system is just in the experimental stage. When finished this is what I will do: eth0 is broken (60% packet loss for no reason). eth1, 2, and 3 will be separate networks, and eth4 is the SAN NIC. If eth1 breaks too (also on motherboard), then eth5 (10Gbps) will replace eth1 (1Gbps). I wouldn't use a bridge as a failover; it probably wouldn't work. I would use link aggregation for failover. –  Peter Jul 4 '12 at 6:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.