Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've a somewhat irritating problem with a Dell 2970 that has a HP 1/8 G2 autoloader (the Ultrium LTO 2 model) attached to the Dell/LSI 2032 non-RAID SCSI card.

In essence, sometimes the autoloader/drive completely fails to appear on the SCSI chain (i.e.: there's neither a media changer or tape drive present within the device manager) and sometimes it appears but then subsequently disappears at a seemingly random (yet always inconvenient) time, resulting in backup failures.

On most occasions, there are simply no errors logged in the system event log, but I did manage to capture a series of LSI_SCSI event ID 11 ("The driver detected a controller error on \Device\RaidPort0") errors followed by an event ID 129, ("Reset to device, \Device\RaidPort0, was issued") error during testing.

I've tried two different cables, both with the same effect – sometimes the autoloader appears (for a while), sometimes it's completely absent. There's only one terminator I've tried to use, but as I've since successfully tested the autoloader on multiple occasions (albeit via a Adaptec U160 card on a different machine), my gut feel is that the issue doesn't lie with the terminator, or indeed the autoloader itself.

As such, I'm just wondering if anyone has any ideas?

It's most likely not relevant, but this is all under Windows SBS 2008, running Backup Exec 12.5 SBS edition (the Dell version), both fully patched. Addidtionally, the autoloader is running the latest firmware.

It's been a while since I've dealt with anything SCSI, so all suggestions will be gratefully, gratefully received.

share|improve this question
    
looks like a scsi reset to me. Do you have the HBA firmware and drivers also fully patched? –  dyasny Jul 3 '12 at 13:51
    
The 1/8 Autoloader has a network-enabled management interface. What do its logs say? –  ewwhite Jul 3 '12 at 13:52
    
LTO2... how old is this device? Is it possible that the device is dying from age? –  HopelessN00b Jul 3 '12 at 13:57
    
@ewwhite There are no log entries that I can find on the HP which hint at any error. –  middaparka Jul 3 '12 at 13:58
    
@dyasny I believe so. When you say HBA, do you mean the LSI drivers, or ? (I'm from a Linux background.) –  middaparka Jul 3 '12 at 14:00

2 Answers 2

I'd suggest installing the HP Library and Tape Tools to run diagnostics on the drive, especially if the device(s) drop off fo the SCSI chain mid-backup.

I typically use LSI-based controllers with HP tape drives and haven't had any odd interactions. Firmware is also important, but more important on the drive side in this case. The driver, tools and firmware for your OS are available here.

share|improve this answer
    
It's currently running a test. :-) That said, I can't use the HP drivers, as Backup Exec tends to get pissy if you don't use the Symantec drivers. However, the precise problem has occurred in the past using the HP drivers, as it was using these before I went through the Symantec troubleshooting. (I'm beginning to wonder if it's a physical seating issue with the LSI card - it does feel a bit flimsy in the screwless slot system the Dell uses.) –  middaparka Jul 3 '12 at 14:19
    
"The test has PASSED and the drive is GOOD", according to the library and tape tools. –  middaparka Jul 3 '12 at 14:43
up vote 0 down vote accepted

Arrghh... It transpired that it was the fact that automatic termination was enabled in the LSI BIOS and there was a physical terminator attached to the autoloader.

As such, removing the terminator solved the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.