Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue where I am reverse proxying from an IIS 6.0 server to an apache server which is serving PNG files with no extension. Strangly it serves files with a "." but nothing else, for example:

"http://internalserver/proxy/image."

I tried adding the MIME type "." and even ".*" to the IIS virtual directory and the server (via IIS MMC snap-in) but this hasn't seemed to solve the issue. Adding the mime type worked when testing other obscure extensions e.g. image.x, image.] etc, but if you have the filename and the "." and nothing else after it, it seems to fail with 404.

Any clues?

share|improve this question
add comment

2 Answers

Try adding an entry called * with application/octet-stream as the MIME Type.

share|improve this answer
    
@AdamB I did try that, adding a "" results in "." but still the same problem. I am wondering if its related to the fact that windows does not support filenames with only a "." extension and hence IIS follows suit. –  Student for Life Jul 15 '09 at 3:17
    
Did you stop and start IIS? –  Adam Brand Jul 15 '09 at 3:41
    
Here are some instructions with pics: serverintellect.com/support/iis6/enable-no-extensions.aspx –  Adam Brand Jul 15 '09 at 3:42
add comment

If I remember correctly, the Win32 subsystem that all applications use, strips off the trailing . from all file paths - so IIS might try to be smart and do it itself.

Is the . present in the real file name? If yes, does it have to be? (Usually files without extension don't have the . either.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.