Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Admittedly, I'm not very UNIX savvy but here's my question anyway. I'm trying to install monit in my "user space" and am receiving this message:

>./configure --prefix=/usr/home/peter
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING: Makefile.in seems to ignore the --datarootdir setting
config.status: creating config.h
config.status: config.h is unchanged
>make
make: Permission denied

My hosting provider says I have make permissions but that it is still trying to install in /usr/local where I have no permissions. Anyone one have any thoughts? modify configure file somehow? I can't seem to find any documentation on configure options? Thanks.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Try running "configure --help" to see if there are any other relevant options. I haven't tried monit in particular, but sometimes, if you're trying to install an application from source, you may need GNU make (which you may need to also install and have in your path ahead of FreeBSD's make.

This is odd, though, as --prefix is often all that's needed to do what you want.

EDIT: I Just tried an install of monit to /tmp/monit as a non-root user (using --prefix), and it worked fine. I just had to use "gmake" (GNU make, as installed from ports). Give that a try. (BTW, I had to un-tar the source file from /usr/ports/distfiles into /tmp in order for this to work. You may not have enough permissions from within /usr/ports to do a build from there.)

share|improve this answer
    
gmake worked for me. I'll have to remember that for next time. Thanks. –  lumberg55 Jul 14 '09 at 15:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.