Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm correctly get following error. After searching about this issue, correct me if i'm wrong, I believe that adding/configuring IPv6 should solve the problem.

PHP Fatal error:  Uncaught CurlException: 7: Failed to connect to 2a03:2880:10:8f02:face:b00c:0:26: Network is unreachable\n  thrown in /var/www/vhosts/facedex.net/httpdocs/fb/apps/seemyfuture/src/base_facebook.php on line 886

The problem is I dont know the right way to add it. There seems to have may methods. http://tldp.org/HOWTO/Linux+IPv6-HOWTO/x1035.html#AEN1044 http://unix.stackexchange.com/questions/34093/static-ipv4-ipv6-configuration-on-centos-6-2

My netstat show this. Shell doesnt recogize -rn6 though.It shows invalid option -- 6

netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
27.254.38.128   0.0.0.0         255.255.255.128 U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         27.254.38.254   0.0.0.0         UG        0 0          0 eth0

FYI: I'm using Centos 5.7.

Thank you a lot in advance.

share|improve this question
    
Can you show your IPv6 route table? netstat -rn6 –  bahamat Jul 3 '12 at 18:05
    
netstat -rn6 shows invalid option -- 6 so i put -rn instead. Above is the output. Not sure this is what you want to see –  Nick Jul 4 '12 at 2:29
    
How about /sbin/ip -f inet6 route show? You'll need the iproute2 package installed. If this still has no output then mgroven is right. –  bahamat Jul 4 '12 at 5:18
    
f e80::/64 dev eth0 metric 256 expires 21110466sec mtu 1500 advmss 1440 hoplimit 4294967295 Does this mean anything? –  Nick Jul 4 '12 at 7:03
    
It means you don't have an IPv6 address. –  bahamat Jul 4 '12 at 7:25

3 Answers 3

up vote 0 down vote accepted

I'm assuming that you don't actually have IPv6 connectivity, in which case you probably want to disable IPv6.

share|improve this answer

Short of globally disabling ipv6 you can try the --ipv4 argument to curl. I think that is what I used in a similar situation.

share|improve this answer
    
Sorry. How can i do that? i dont know much about server –  Nick Jul 4 '12 at 11:07

You can't just arbitrarily configure IPv6. You need to get IPv6 from your ISP, or create a tunnel with Hurricane Electric, Gogo6 or similar.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.