Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get the Nagios XI virtual machine working on Hyper-V (yes, I know it's not a supported config). I'm trying to get it on the network to download some packages so that I can then install the Enlightenment components and use a synthetic adapter.

I've configured the machine with a legacy adapter which is correctly recognised as eth0, and it picks up a DHCP lease, but after that I can't seem to get any traffic to traverse the network at all. The same virtual network is being used for other guest machines so I know it's working. My Linux skills are limited. Can anyone help?

EDIT: I can ping the leased address from the machine itself, but cannot ping any other address on the same subnet, nor can any other machines ping this erver.

The VM is running CentOS 6.2. Kernel 2.6.32-220.17.1.el6.i686

UPDATE 5-Jul-2012

I have set up a brand new VM on a different server using the same source VHD. This time I configured the machine using a static IP address, but the end result is the same. dmesg | grep eth yields:

enter image description here

share|improve this question
What flavor of Linux is this running on? – Bart De Vos Jul 4 '12 at 11:45
CentOS, it's a pre-built VHD image from Nagios. I'll put full details in an edit. – Chris McKeown Jul 4 '12 at 11:58
up vote 2 down vote accepted

I've fixed this by adding noapic to the kernel options in grub.conf

This has enabled the legacy network adapter to work properly. I'm currently downloading the Development Tools package to allow me to install the Hyper-V enlightenment drivers and then I'll try removing that option again.

EDIT: Success!

After installing the development tools, then the integration components version 3.2 and removing the noapic option, the machine is now able to use a synthetic adapter. It's important to remove the noapic option before rebooting after installing the integration components, or you get a kernel panic at boot.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.