Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have successfully installed centos on a virtual machine via Hyper-V on Windows Server 2008 R2. This server has one NIC.

I have created a virtual NIC, and virtual subnet, and within the virtual machine (via console) I can ping the gateway. But not google. Is there certain steps I am missing, I feel like I'm one setting away.

Im not sure what other information would be useful.

Here is the ipconfig of the host:

Ethernet adapter vNIC losangeles1_1:

Connection-specific DNS Suffix .. :
IPv4 Address. . . . . . . . . . . : 10.10.0.1
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :


Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix .. :
IPv4 Address. . . . . . . . . . . : 72.51.43.43
Subnet Mask . . . . . . . . . . . : 255.255.255.192
Default Gateway . . . . . . . . . : 72.51.43.1 

Here is the Virtual Network Manager of the host:

enter image description here

share|improve this question
    
(not letting me use html tags), anyways the virtual has an inet address of 10.10.0.2 and a bcast of 10.10.0.255 and a mask of 255.255.255.0 –  Cameron Aziz Jul 4 '12 at 21:27
    
So <br>, we meet again. sigh –  Wesley Jul 6 '12 at 1:11
    
it was better than what it was letting be do before. what would the correct way to format –  Cameron Aziz Jul 6 '12 at 1:20
    
Code block it. I'll show you... done! –  Wesley Jul 6 '12 at 1:21
    
4 spaces, eh? merci –  Cameron Aziz Jul 6 '12 at 1:24

2 Answers 2

When you created your virtual network, you probably chose an 'Internal' type. This does not allow traffic out of the machine (unless you monkey around installing a loopback adapter on your host and route the traffic through that).

You need to create an External virtual network.

share|improve this answer
    
can an internal be changed, or do I have to delete and start over? –  Cameron Aziz Jul 4 '12 at 21:28
    
Just create a new External network, and change the VM's NIC to use that network. You don't even need to reboot the VM. EDIT: And most importantly, make sure you enable the network to be shared by the Host otherwise you'll cut your host machine off the network if it only has a single NIC! –  Chris McKeown Jul 4 '12 at 21:32
    
just to make sure I don't make a mistake, mind stating how to "enable the network to be shared by the host" Thanks so far! –  Cameron Aziz Jul 4 '12 at 22:28
    
It's the "Allow management operating system to share this network adapter" option. That needs to be enabled. –  Chris McKeown Jul 4 '12 at 22:39
    
@CameronAziz Change the network type in the HV manager: Virtual Network Manager, select the existing network and change on RHS. And ensure you allow the "management operating system" to share the NIC. –  Richard Jul 5 '12 at 7:00

you said you can ping the gateway, is that a router or something on your network? Or do mean the host PC that is running Hyper-V? If you could post the output of an ipconfig /all from your hyper-v host and the output of an ifconfig eth0 from your centos VM that would give us a better insight.

As Chris points out you've most likely chosen the 'internal' connection type option when configuring your virtual NIC.

Go to hyper-V manager, select your host and then on the right side of the screen click 'Virtual Network Manager'. In the window you get now, select you virtual network from the 'virtual networks' list (normally you should only see one in your situation). Now select 'External' under the 'Connection Type' pane, select your physical NIC that you want to use, and make sure you check 'Allow Managerment OS to share this network adapter'

That should do the trick

share|improve this answer
    
I can ping the gateway, meaning from the virtual, I can ping the virtual nic (10.10.0.1) while the virtual has the ip of 10.10.0.2. –  Cameron Aziz Jul 4 '12 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.