Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Im trying to use my sbs essentials 2011 server to allow users to remote into their machiens remotely

everything is setup on the server but when I try to remote i get the error

"this computer can't verify the identity of the rd gateway" xxxxx" its not safe to connect to servers that can't be idendified. contact your network administrator for assistance"

this seems like a cert error so i googled it and i found this website http://www.andrewstechnology.co.uk/reference/tips/44-sbs2011-rd-gateway-cant-verify-error.html

that says there should be a package that i can download and install on home computer to install the certs locally

the problem is that the instructions are for standard edition of sbs and not essentials and the path given doesnt seem to exisit

can anyone point me in the right direction?

share|improve this question

2 Answers 2

up vote 0 down vote accepted
+50

According to this thread, you can't. (And I haven't been able to find anything saying you can, nor do I have a copy of SBS to run tests on.)

SBS Essentials should be setup using a trusted SSL certificate from a commercial CA, like GoDaddy / Enom.

There is no Cert Package.zip on SBS Essentials.

If you have setup the server and used all of the Wizards for remote access you will have already installed a valid cert - so my guess is you have not done this.

A couple posts down, it also says you can't do a self-signed cert on SBS essentials either. (Kinda makes me wonder what in the hell the supposed market for this particular OS is, given that it looks like it's more expensive than some of the 2k8 standard offerings. :? But I digress.)

I would try (and this may or may not work, and may or may not violate your licensing agreement, I have no clue) downloading the Install Certificate Package.zip file from a SBS 2011 server, putting it in the expected path and seeing what happens (on a test machine, obviously). Not sure if SBS 2011 essentials has the required services installed to process a certificate request, or even if the .exe is compiled/built by the specific machine it's hosted on, but it seems worth a try.

Failing that, it's buying a cert from a third party CA or living without that functionality. And maybe a lesson in why it's usually not a good idea to save $100 on an OS license if you have to sacrifice fundamental functionality to do so. (Probably a lesson for your boss. Be careful about how and if you mention that lesson, though.)

share|improve this answer

Just install the Certificate in Internet Explorer into your Trusted Roots on your client computer.

Instructions here: http://blogs.technet.com/b/sbs/archive/2007/04/10/installing-a-self-signed-certificate-as-a-trusted-root-ca-in-windows-vista.aspx

  1. Connect trough Internet Explorer to your RDP site
  2. Choose "Continue to this website (not recommended)".
  3. Click on “Certificate Error” beside the address bar and select view certificates.
    • If you do not see the Install Certificate option close IE7 and then right click on IE7 and choose run as administrator and load the page again.
  4. Once you have the install certificate button available, select "Install Certificate".
  5. This will launch the Certificate Import Wizard. Make sure to Choose the option “Place all certificates in the following store” and select browse.
  6. Select Trusted Root Certification Authorities and click Ok.
    • In some cases you have to check show physical stores, then select “Local Computer” under Trusted Root Certification Authorities.
  7. Click Finish on Completing the Certificate Import Wizard
  8. Click yes on the security warning to install the certificate
share|improve this answer
    
thanks for the pointer but there is no "install certficate..." button (im using ie9 so maybe that?)i50.tinypic.com/2rop6om.png –  Crash893 Jul 17 '12 at 20:23
    
•If you do not see the Install Certificate option close IE7 and then right click on IE7 and choose run as administrator and load the page again. (Should be the same with IE9) –  MichelZ Jul 17 '12 at 21:13
    
I do see it now I'll try it and report back –  Crash893 Jul 18 '12 at 6:26
    
I get the message that the import (to trusted root cert authorities) was succesfull but i still have the same issue. Reboot? –  Crash893 Jul 18 '12 at 6:27
    
A reboot should not be necessary. Could you post screenshots of the errors and of the certificate? –  MichelZ Jul 18 '12 at 6:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.