Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a weird problem that I don't even know where to begin diagnosing. Trying to install Ubuntu to a VM locks up the host system!

My setup is:

  • Dell R715 server, dual 16 core AMD opteron processors, 96GB RAM
  • Dell MD3600f SAN
  • Server 2008 R2 Datacenter
  • System Center VMM 2012

There are 5 windows virtual machines running that have had no problems. This is the first linux VM I've tried to create. I setup a VM through virtual machine manager, set the CD drive to a Ubuntu 12.04 server x64 iso, and started it up.

It boots up the normal ubuntu install menu, but the second I hit enter on "Install Ubuntu Server", I get disconnected.

The HOST machine stops responding to pings. So do all virtual machines on it. It locks up entirely - keyboard on the host won't work, mouse won't move, numlock light won't change.

There's no blue screen - the host is sitting at the login screen completely unresponsive. I can't find any relevant logs in event viewer after rebooting.

What could cause the host machine to freeze like that?

It's not a one time occurrence - it happens every time at the exact same point. Thank god this server isn't in production yet!


It doesn't seem to be a hardware problem. I fired up a dozen extra virtual machines to see if I was maybe hitting a bad spot of RAM, but everything worked fine.

Ubuntu 10.04 installed with no issues.

When doing a do-release-upgrade from 10.04 to 12.04, it got part way through the upgrade before it threw the root filesystem into read only mode and started getting tons of IO errors. Not a disk issue since I was able to run hard drive benchmarks and read/write large files before I started the upgrade.

Next things to test are 12.04 alternate CD, and 12.04 32bit and see if they show the same behavior.

Update 2

Well now this is was consistently freezing on Thursday and Friday, at least 20 times in the same spot. Nothing changed over the weekend. I'm the only one who has access to the server at the moment. And today I can boot that ISO just fine without any crashes.

I hate problems that go away on their own. I was hoping to narrow it down so I could at least know what not to do when it goes into production.

share|improve this question
up vote 3 down vote accepted

When you say Windows Updates are installed, are you referring to the Windows Update applet, or did you check for the Hyper-V hotfixes on the Microsoft web site? Here are a few:

2550569 - 0x20001 Stop error when you start a Linux VM in Windows Server 2008 R2 SP1

2517329 - Performance decreases in Windows Server 2008 R2 when the Hyper-V role is installed on a computer that uses Intel Westmere or Sandy Bridge processors

2636573 - FIX The guest operating system may crash when you perform a live migration of Hyper-V vm in Windows Server 2008 R2

2263829 - The network connection of a running Hyper-V virtual machine may be lost under heavy outgoing network traffic on a computer that is running Windows Server 2008 R2 SP1


2568088 - Virtual machine does not start on a computer that has an AMD CPU that supports the AVX feature and that is running Windows Server 2008 R2

share|improve this answer
I do not have the first 2 installed. Though they appear to only affect intel CPUs, I'll try installing them anyways and see if it makes a difference. The 3rd and 4th ones are already installed. – Grant Jul 6 '12 at 13:55
Understood. There is one specific to AMD, 2568088. I edited the answer with that information. – Greg Askew Jul 6 '12 at 14:07
2568088 is definitely installed, since I ran into that issue where no VMs would start. – Grant Jul 6 '12 at 14:48
+1 I really have seen some of these issues with Hyper-V 2008 R2 in the past. – the-wabbit Nov 13 '12 at 7:28

What could cause the host machine to freeze like that?

Defective hardware, defective Drivers, defective OS.

Simple like that.

Start with checking all updates, that the drivers are current and that the hardware is good.

share|improve this answer
Windows updates are all installed. When I installed the machine less than a month ago I ran it through Dell's built in diagnostics, a weekend of memtest, and after installing windows a couple days of running many copies of Prime 95. – Grant Jul 5 '12 at 14:39
You could always open a MS PSS SUpport case. Yes, Ubuntu is not supported, but the Hyper.Visor freezing means in a public cloud some idiot customer so to say yould shut down your servers - not support, it should NOT shut down the hyperviror, Period. If that is not a driver issue, MS may WANT to investigate that. – TomTom Jul 5 '12 at 15:00
Well, ok - anyhow, issue here being: whatever you do in a VM it should NOT NEVER EVER crash the hypervisor. This IS a bug. Even if I try to load something totally unsupported, the hypervisor crashing is not acceptable. – TomTom Jul 5 '12 at 18:05
Definitely a bug, we've got Solaris, among other unsupported OS's running in Hyper-V and I've never seen an issue like this myself. – Tatas Jul 5 '12 at 18:06
I may end up calling MS support. I don't care if ubuntu doesn't work - it's unsupported, I get that. I DO care if things running on the virtual machine can crash the host, intentionally or not. – Grant Jul 6 '12 at 12:07

it could be a memory fault, starting up the VM guest using more memory, but if the host runs normally seems unlikely.

try removing unnecessary virtual hardware from the guest - i.e. disk, network cards etc, and see if you can simply boot off CD. then add each device back one by one to see if it eliminates the problem.

my guess is that it's a "thin" hv_vmbus driver in the guest which is breaking hyper-v, so you might be better off using the legacy network device rather than hv_netvsc for example.

share|improve this answer

I was getting this same thing and thought I would post in case you or anybody else is still having this trouble.

I don't recall which, but there were two settings that come to mind that would trigger this for me.

  1. VM Properties - Processor - disable the different processor version option
  2. VM Properties - HDD - disable contains operating system

Again, I don't recall which one it was, at this point I just disable both when I create a Linux VM.

share|improve this answer
Daniel Scott, thanks for posting your answer, would be great if you could make your answer more precise. – Deer Hunter Jan 14 '13 at 17:55
Can you test and determine exactly which one of the two was the problem? – Michael Hampton Jan 14 '13 at 18:08
I'd love to know for certain which of those causes it. Unfortunately the system is now in production and people would...frown testing something that might intentionally crash it. If you can test it great! – Grant Jan 14 '13 at 18:29

Ubuntu is not supported by hyper-v, only Suse, redhat and Centos are supported.

Not that this means it should crash your Hyper-v host, but still it's something to bear in mind, I've seen some older Linux OS' cause esxi 4 to have a hissy fit for a while, never seen it cause the hypervisor to keel over though.

According to this article Ubuntu have worked toward making their latest release hyper-v compatible, though microsoft haven't certified it yet, so in theory it stands a good chance.

Have you tried the alternative installer disk? This is available from and uses a different installer to the default iso.

share|improve this answer
Alternative install might work. For the moment I tried installing from a 10.04 disk, and that worked perfectly. – Grant Jul 5 '12 at 17:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.