Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: unixd_config

I spent the last hour or so googling, and it seems that I have to create a new PHP5 after installing my new Apache (2.4.2). Debian didn't have Apache 2.4.2 and it's a requirement I was given. I still have the PHP 5.4.4 from Debian wheezy repository. I tried including it in the new Apache 2.4.2 that I installed, but it throws the error you see above. Is there a way to "reglue" everything? I was going to just install a fresh PHP, but I ran into some errors on ./configure, so I wanted to see if there were easier ways before I spend more time on installing a new copy.

share|improve this question
add comment

1 Answer

You could compile PHP yourself

Get the source with

apt-get source php5

then get the dependencies

apt-get build-dep php5

Then a it might work.

share|improve this answer
    
(it's only going to work if you've got the apxs binary for the version of apache you've got installed - and apache is compiled with mod_so - see the apxs man page for more details) –  symcbean Jul 5 '12 at 21:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.