Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a website that is setup on IIS 7 and are trying to replace it with a new site, but need a redirect that is in place removed.

The old site used a custom file as the homepage (WN-main.asp). We removed all the old site files, including web.config, and placed them in a subdirectory for safe keeping.

The new site no longer uses ASP, and we'd like to use a regular index.html as the default. However, when we go to the website, it keeps trying to redirect our .com to .com/WN-main.asp -- and that gives us a 404 Error in the Application for "Default Web Site" because we removed that page.

In the IIS "Default Document" settings we have index.html at the top, and WN-main.asp is nowhere to be found in the list (it never was there). We've also removed the web.config file from the root directory, and put the entire old website in a subdirectory. As well as restarted IIS. We're assuming that the redirect is setup somewhere in IIS because if I navigate to .com/index.html which is our new site, it works. Our problem is that oursite.com redirects to oursite.com/WN-main.asp. Grr. If you go to www.worzalla.com you can see how it redirects to the WN-main.asp page right now as the homepage.

Any ideas where this redirect could have been setup so we can remove it?

Thanks!

share|improve this question

3 Answers 3

Take a look for the IIS Redirect Module, it would be configured under the site settings. You may also have the IIS Rewrite Module as well. You will need to look for the rules there. Also, if you happen to have a load balancer or some other intelligent device between your server and the internet you will also need to check there.

share|improve this answer
    
Thanks, checking this today! –  Kim L Jul 9 '12 at 13:53

A redirect could also be setup in IIS manager under HTTP redirect or in an ISAPI filter

share|improve this answer
    
Thanks, checking this today! –  Kim L Jul 9 '12 at 13:53
up vote 0 down vote accepted

Found nothing in the IIS Redirect Module, and had checked it multiple times. We disabled and enabled it.

We are not sure exactly what ended up being the issue - somewhere, somehow, the old homepage was possibly cached on the server and the page itself had a redirect to the /WN-main.asp page...even though the server should not have been caching anything and we had checked that multiple times initially. After playing around with lots of settings, it just suddenly started working! Grrr Microsoft. The fact that we disabled and enabled asp and .net may have helped, but I'm not sure...at least it's working now!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.