Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

All this is performed on Ubuntu 10.04.4 LTS Server

After installation, I get the following error: I have tried to use as suggested luarock and sudo apt-get install to fix these. But still it keeps showing me these errors.

Selecting previously deselected package prosody. (Reading database ...
59416 files and directories currently installed.) Unpacking prosody
(from prosody_0.8.2-1_i386.deb) ... Setting up prosody (0.8.2-1) ... 
* Starting Prosody XMPP Server prosody
************************** Prosody was unable to find luaexpat This package can be obtained in the following ways:

        Source:           www[dot]keplerproject[dot]org/luaexpat/
        Debian/Ubuntu:    sudo apt-get install liblua5.1-expat0
        luarocks:         luarocks install luaexpat

luaexpat is required for Prosody to run, so we will now exit. More
help can be found on our website, at prosody[dot]im/doc/depends
**************************


************************** Prosody was unable to find luasocket This package can be obtained in the following ways:

        Source:           www[dot]tecgraf[dot]puc-rio[dot]br/~diego/professional/luasocket/
        Debian/Ubuntu:    sudo apt-get install liblua5.1-socket2
        luarocks:         luarocks install luasocket

luasocket is required for Prosody to run, so we will now exit. More
help can be found on our website, at prosody[dot]im/doc/depends
**************************


************************** Prosody was unable to find LuaSec This package can be obtained in the following ways:

        Source:           www[dot]inf[dot]puc-rio[dot]br/~brunoos/luasec/
        Debian/Ubuntu:    prosody[dot]im/download/start#debian_and_ubuntu
        luarocks:         luarocks install luasec

SSL/TLS support will not be available More help can be found on our
website, at prosody[dot]im/doc/depends
**************************

                                                                         [fail] invoke-rc.d: initscript prosody, action "start" failed. dpkg:
error processing prosody (--install):  subprocess installed
post-installation script returned error exit status 1 Processing
triggers for man-db ... Processing triggers for ureadahead ... Errors
were encountered while processing:  prosody

Thanks a lot for your patience and answers.

share|improve this question
1  
Any reason 5.1.2 from the Ubuntu repository doesn't work? –  Shane Madden Jul 6 '12 at 1:54
    
Good to know. Is there a question you wanted to ask? –  womble Jul 6 '12 at 5:27

1 Answer 1

Try

sudo apt-get install --fix-missing
share|improve this answer
    
Did not work. same error. –  user90374 Jul 6 '12 at 0:41
    
I noticed all those libraries are installed. I get this "liblua5.1-expat0 is already the newest version".Main issue is : Prosody was unable to find luaexpat –  user90374 Jul 6 '12 at 0:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.