Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a fresh installation of Munin 2.0.1 on my Ubuntu 12.04 and the first time I tried to view graphs, it showed them properly(After installation, I had to follow http://munin-monitoring.org/wiki/CgiHowto2 to set it up) After that, the graphs show up, but with with just one data point(single vertical line) as if no data is being collected after I tried it for the first time.

In Munin 1.4, there was munin-cron which was run every 5 minutes and I saw new data being plotted in the graph atleast every 5 minutes. But If there is no cron job in v2, How does data collection work with Munin2 ? Is the data collected when the graphs are requested ? The file timestamps in /var/lib/munin have not changed after the first time I tried the graphs. But i do see munin-node process running(restarted in several times). I also see no errors in the munin node log files or apache2 log files.

Any idea what could be wrong ?

Screenshot : http://i.imgur.com/uzuAK.png

Also, is there a way to pre-create graphs instead of doing it dynamically, on the fly ?

share|improve this question
add comment

1 Answer

Munin 2 also uses cron to collect data, so if you are missing data you should check that the cron script is running and that your munin-node is running.

Munin 2 allows for the graphs to be rendered on-demand, in previous versions graphs where rendered every 5 minutes, so this is a a great thing because it cuts down on processing power. But it has to collect data from the nodes to be able to create the graphs on demand.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.