Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am installing software and one of the dependencies is mod_perl, when i run

  #perl Makefile.PL 

I receive this error:

***** WARNING *****

Your Perl is configured to link against libgdbm,

but libgdbm.so was not found.

You could just symlink it to /usr/lib/libgdbm.so.2.0.0

EDIT: I am using RHEL 5

HELP me???

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

I ran into this issue awhile back, check to see if libgdbm is installed, if it is do the following to ensure its linked correctly:

Just noticed you said you were using RHEL5 same system I was using so these should work perfectly for you

ls -l /usr/lib/libgdbm.so*

It may look similar to this:

/usr/lib/libgdbm.so.2 -> libgdbm.so.2.0.0
/usr/lib/libgdbm.so.2.0.0

If so you can run this command to symlink

cd /usr/lib
ln -s libgdbm.so.2.0.0 libgdbm.so

Then run the command again:

ls -l /usr/lib/libgdbm.so*  

should look something like this:

/usr/lib/libgdbm.so -> libgdbm.so.2.0.0
/usr/lib/libgdbm.so.2 -> libgdbm.so.2.0.0
/usr/lib/libgdbm.so.2.0.0

Try to install again

share|improve this answer
1  
THANKS! Your solution worked for me. –  Tsevg9 Jul 6 '12 at 14:54
    
Your welcome! I just did this about two weeks ago –  JMeterX Jul 6 '12 at 14:56
add comment

It's more helpful to give an idea of what kind of system you're talking about.

Just for grins, I'm going to guess Ubuntu Linux.

You could do exactly what it says: read the manpage for ln(1) for more details on symlinks, but:

 ln -s /usr/lib/libgdbm.so.2.0.0 /usr/lib/lbgdbm.so

might just fix your problem.

It might not, because there are so many other things that could affect this and you have not narrowed down the field much for us.

I would suspect that a better approach would be to use your system's native package manager, if my guess at ubuntu is correct, I think you want:

apt-get install libapache2-mod-perl2

If the native package manager approach won't work for you, even more reason why you need to give more information and write a better question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.