Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I took a copy of a VM running a debian, just so that I can play around with it. I spin up the copy, but didn't give it any network connection to avoid conflict with the original one. However, when I turn the VM on, it seems to freeze after this startup message

Starting Sambe daemons:nmbd smbd
Starting PostgreSQL 8.4 database server: main    
Starting the Winbind daemon: winbind

how do i fix this? I never get to the prompt to login. This vm does have a mount point that connects to a windows share folder.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Some processes don't handle it well when they're started up without valid network connectivity.

Your best bet would be to boot the VM into single-user mode (you don't mention what VM system you're using, but if you can get to the GRUB Linux kernel boot menu, edit the kernel line to add the word single at the end). In single-user mode, the OS won't start up any services or applications. You can then go in and disable winbind (and any other services you might need to turn off).

On Debian, the easiest way to do this would probably be:

sudo update-rc.d winbind disable

Or, you can do it manually with something like:

sudo rm /etc/rc3.d/S??winbind

After making that change, exit out to let your VM finish booting. After it's booted up, and you have a valid working network config in place, you can start winbind again with:

sudo /etc/init.d/winbind start
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.