Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a HP DL380 and after I leave it on for a while it decides it needs to run the fans at a much higher speed than it did before. It's really loud and annoying. Is there any way to manually control the fan speed? Or otherwise get it to stop doing that? Thanks.

edit: I guess i should have made it clear that this is a bit of a jury-rigged situation. I know the ideal solution is to put the thing in a server room with nice cool air. Unfortunately, that isn't happening. This is the sort of problem that calls for a jury rigged solution like

  • manually setting the fan speed and accepting the fact that it's going to run hot
  • shutting down a CPU (can i do that?)
  • spinning down the disks when they're not in use (is that possible?)

solution: Install HP's system health monitoring daemon, hpasmd. I installed it to try to figure out what was going on, and just running it fixed the problem.

share|improve this question
add comment

7 Answers

up vote 6 down vote accepted

Some rackmount HP machines that I've worked on in the past were known to run their fans at full tilt until a proprietary driver or software package is loaded in the OS. Then they would be relaxed down.

What OS are you using? Have you installed all of the recommended drivers/packages?

share|improve this answer
    
i'm running linux. I've installed the "hpasm" tool which runs some sort of system monitoring daemon and lets me check the temperature and fan speed etc. –  smoofra Jul 14 '09 at 16:23
    
Is there any noticeable difference between the time that the machine is booting and when HPASM is loaded? Have you started HPASM with the command hpasm activate? –  Dan Carley Jul 14 '09 at 16:26
    
just running hpasmd all the time seems to solve the problem. –  smoofra Mar 17 '10 at 14:39
add comment

Put it in a cooler room or feed it more cool air. The fans typically ramp up as more cooling is needed. Are you monitoring any of the temp sensors to see how warm it is when it gets loud?

share|improve this answer
    
If that was an option I would have done it :/ –  smoofra Jul 14 '09 at 16:04
    
Which? Cool air or temp monitoring? I guess I should've asked, just where is this thing, anyways? Under a desk? In a server room? –  Chris_K Jul 14 '09 at 16:07
    
> which? Cool air or temp monitoring? Cool air. The temp is 109 in "I/O_ZONE" and 104 in CPU#1. Which is hot but it seems like it wouldn't melt if it was a bit hotter. –  smoofra Jul 14 '09 at 16:10
2  
@smoofra: Then you're going to have to live with the sound. –  Evan Anderson Jul 14 '09 at 16:11
    
"but it seems like it wouldn't melt if it was a bit hotter." Are you willing to test that theory by disabling or limiting the fan speed? To me, a loud system is better than a broken system. –  Russ Warren Jul 14 '09 at 16:17
show 1 more comment

Check your CPU usage to make sure some rogue process isn't running the CPU 100% of the time, increasing heat, causing the fans to run full-bore.

share|improve this answer
add comment

Modern computers often have a self regulating thermal control unit. If the unit is turning on the fan, I wouldn't suggest trying to shut it off. It probably needs the air flow.

Speaking of which, make sure the entire computer -- the entire case -- isn't being blocked. The computer will need room to "breath". All vents should be free of any clutter and dust.

Assuming everything is as it should be if it continues, the server (or computer) may be being taxed excessively. What are you using it for?

UPDATE: based on your revision, I think you should check to see if you can "turn down" the processor. This is the oposite of overclocking though this can sometimes be done from the BIOS. (I'm only suggesting this if it can be done in the BIOS. ). If you can decrease the clock speed of the processor, it may not run as hot.

But, it still stand to ensure that the computer can receive proper air flow -- even if that air is room temperature.

You may even want to consider adding some holes and additional external fans to the casing, if that is possible.

share|improve this answer
add comment

Probably not relevant, but I once had a new DL 380 that ran the fans at high speed all the time. The issue turned out to be that the two CPU's were mismatched (different stepping levels I recall).

When the mismatch was resolved it behaved normally.

share|improve this answer
add comment
  • Upgrade last bios (2011)
  • reboot the server
  • Unplugg all power cable
  • Push power-on buttom for 8 seg.
  • now plug all power cable again and that it.

Other option is using the smartstart CD go and clean the IML log.

share|improve this answer
add comment

There might be some settings in the BIOS. But from my experience it takes a good amount of heat for those fans to kick on so high... I have only heard them full bore while rebooting or the drivers are not working in the OS correctly. I also noticed with VMware ESXi the fans run a little faster then the slowest speed after I did a BIOS update...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.